[B2G][Leo][APZ]Scrolling with APZ turned off causes graphical anomalies

RESOLVED DUPLICATE of bug 909877

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 909877
4 years ago
4 years ago

People

(Reporter: PBylenga, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Description:
Scrolling in Contacts, Music, Settings around SIM card, and Developer Options with APZ turned OFF causes graphical anomalies on a Leo device with v1.3 flashed to it.

Repro Steps:
1) Updated Leo to Build ID: 20140108004001
2) Launch Contacts App with multiple contacts imported/created
3) Scroll moderately fast and observe

Actual:
Multiple graphical anomalies and distortions

Expected:
Smooth repainting without issue

Environmental Variables
Device: Leo v1.3 Mozilla RIL
Build ID: 20140108004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/2287f2839256
Gaia: 522779225e86b7a4d1bf759036678dc321a1486e
Platform Version: 28.0a2
Firmware Version: V10d

Notes:
Repro frequency: 5/5, 100%
See video:
https://www.youtube.com/watch?v=kh5Ok9Yo-Vs


Workaround: Turning ON APZ in Developer options causes this bug not to reproduce.
APZC is getting turned on in tomorrow's build, so this isn't valid.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID

Comment 2

4 years ago
Reopening, as this bug was filed against a build with APZ disabled.   please retest this case on a new 1.3 build after bug 909877 is uplifted.   If it doesnt reproduce, you can mark this resolved fixed by that bug.

Thanks,
Tony
Status: RESOLVED → REOPENED
Flags: needinfo?(pbylenga)
Resolution: INVALID → ---
(In reply to Tony Chung [:tchung] from comment #2)
> Reopening, as this bug was filed against a build with APZ disabled.   please
> retest this case on a new 1.3 build after bug 909877 is uplifted.   If it
> doesnt reproduce, you can mark this resolved fixed by that bug.
> 
> Thanks,
> Tony

This is a preffable feature that can be tested already to confirm if this happens or not. There's bugs already open tracking APZC issues present that users will hit, which is different than the bugs present here. This feature will not remain preffed off in 1.3, so bugs filed with this off are no longer valid. The tester has already indicated in the first comment that this bug does not reproduce with APZC turned on, so this isn't going to happen with the landing of bug 909877. There's no value to retest this again, as the tester has already confirmed this is fixed by turning the feature on.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(pbylenga)
Resolution: --- → INVALID
I'll dupe it to the gaia-apzc bug then to say it's fixed by that.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 909877
You need to log in before you can comment on or make changes to this bug.