[fugu][buri][settings] cannot backward from keyboard settings

VERIFIED FIXED in Firefox OS v1.3

Status

Firefox OS
Gaia::Settings
--
critical
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: Peipei Cheng (needinfo if you need my action), Assigned: GaryChen)

Tracking

({regression})

unspecified
1.3 C2/1.4 S2(17jan)
Other
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed)

Details

(Whiteboard: burirun1.3-2)

Attachments

(1 attachment)

This is a regression from v1.2.

Test Environment:
--------------------------
Buri V1.3
Gaia      522779225e86b7a4d1bf759036678dc321a1486e                         
Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/2287f2839256   
BuildID   20140108004001                                                   
Version   28.0a2                                                           
ro.build.version.incremental=eng.archermind.20131114.105818                
ro.build.date=Thu Nov 14 10:58:33 CST 2013 

Reproduce Steps:
--------------------------
1. Launch Settings
2. go to Keyboards -> Built-in keyboards, keyboard settings page appears
3. Tap on the backward button
   --> A black screen appears. User cannot do any operation.

Btw, I also tested with follow build. The behavior is the page switches between Built-in keyboards and keyboard settings.

Gaia ff5f06dd321f7d2bf4a5b311ded2c56e865d4f83
Gecko http://hg.mozilla.org/releases/mozilla-aurora/rev/71ad7ff30010
BuildID 20140107004001
Version 28.0a2
ro.build.version.incremental=eng.archermind.20131114.105818
ro.build.date=Thu Nov 14 10:58:33 CST 2013
blocking-b2g: --- → 1.3?
Severity: major → critical

Updated

5 years ago
Keywords: regression, regressionwindow-wanted
Duplicate of this bug: 957987
The regression window is 1/7 to 1/8. Appears related to the 1.3 uplift of bug 947033.

Last build that the issue does not reproduce:

Environmental Variables
Device: Buri v1.3 Mozilla RIL
Build ID: 20140107004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/71ad7ff30010
Gaia: ff5f06dd321f7d2bf4a5b311ded2c56e865d4f83
Platform Version: 28.0a2
Firmware Version: 20131115


First build that the issue reproduces:

Environmental Variables
Device: Buri v1.3 Mozilla RIL
Build ID: 20140108004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/2287f2839256
Gaia: 522779225e86b7a4d1bf759036678dc321a1486e
Platform Version: 28.0a2
Firmware Version: 20131115
Keywords: regressionwindow-wanted
QA Contact: pbylenga
After removing |window.close()|, black screen still appears but user can tap home button to back to homescreen.

It might be a windows_manager issue or gecko issue. 
https://github.com/mozilla-b2g/gaia/blob/v1.3/apps/keyboard/js/settings/settings.js#L19

please refer to bug 957987#c1
Hi all,
   I found the root cause.
   Since |settings.webActivityHandler| will fallback into |activityRequest.postError| and then |WindowManager| will set ActivityCaller(keybaord APP) to frontend, but there is something wrong in |WindowManager|, so we will get black screen in this scenario.

   Even |WindowManager| resolved this issue, the flow still not correct as I mentioned above |WindowManager| will bring keyboard into frontend, so I add additional flag |postback: false| to resolve this bug. 

   And also I will file another bug for |WindowManager|.

   https://github.com/mozilla-b2g/gaia/blob/v1.3/apps/settings/js/settings.js#L590
   https://github.com/mozilla-b2g/gaia/blob/v1.3/apps/system/js/window.js#L241
Assignee: nobody → gchen
Created attachment 8359073 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/15239

Hi Arthur and Rudy,
   Please help to review my patch, it is for v1.3 only.

   Thanks.
Attachment #8359073 - Flags: review?(rlu)
Attachment #8359073 - Flags: review?(arthur.chen)
Comment on attachment 8359073 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/15239

r+ for the keyboard app part and I left some comments on the settings app part.
Please help address that.

Thank you.
Attachment #8359073 - Flags: review?(rlu) → review+
See Also: → bug 959056
As comment 4, here is the follow up bug  bug 959056.

Updated

5 years ago
Whiteboard: burirun1.3-2

Updated

5 years ago
Duplicate of this bug: 959116
Triage: +'ing, functional regression.
blocking-b2g: 1.3? → 1.3+
Comment on attachment 8359073 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/15239

r=me. Thanks!
Attachment #8359073 - Flags: review?(arthur.chen) → review+
travis- passed: 
https://travis-ci.org/mozilla-b2g/gaia/builds/16852563

land in v1.3:
https://github.com/mpizza/gaia/commit/e4a00bee5ce687c37992c64ca6e87f0800667ec3
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g-v1.3: --- → fixed
Resolution: --- → FIXED

Comment 12

5 years ago
Thanks for the help!
Verified it.

* Verified Build: (Device -> Buri)
 - Gaia      47049555282a9a01fb60d1e1421b57e2810c96f5
 - Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/6f7dfe36ab6c
 - BuildID   20140121004137
 - Version   28.0a2

* Result:
 - Cannot reproduce it.
Status: RESOLVED → VERIFIED

Updated

5 years ago
Duplicate of this bug: 962966

Comment 14

4 years ago
bug still exist on v1.4
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → fixed
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
The patch didn't land on 1.4.

This issue was a 1.3-specific window management issue.
status-b2g-v1.4: fixed → ---

Comment 16

4 years ago
(In reply to Joell Lapitan from comment #14)
> bug still exist on v1.4

Hi, Joell,

Do you mean you still can reproduce it?
If so, could you please provide the git commit number and build ID?

I cannot reproduce this bug on following V1.4 build.
Thanks.

* Build information:
 - Gaia      3534b4880653f24529c973ec2f09ef51a3d6392f
 - Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/12171cfe5ded
 - BuildID   20140414160201
 - Version   30.0a2
You need to log in before you can comment on or make changes to this bug.