[PP]linux 'Translate' button on core tools bar fails to generate xul popup

VERIFIED DUPLICATE of bug 8048

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 8048
19 years ago
19 years ago

People

(Reporter: Claudius Gayle, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
*Summary
	The 'translate' button doesn't work on Linux.

*To repro
	Just click on the 'translate' button which is located on the RHS of the 'core tools' aka navigation toolbar.

*Expected result
	With a mousedown a sweet XUL popup window is generated and you can select languages to translate to/from.

*Actual result
	The button is depressed but nothing happens. In the console window the following output is generated:

nsWindow::WidgetToScreen
	x = 4, y = 48
***creating XUL popup at 4 48
nsWidgetFactory::CreateInstance(), unhandled class.

*Build info
	Only occurs on LINUX. Repro'd with RHLinux 5.2 1999070917 build. Tested on WinNT and MacOS with same builds and does
not occur(works rather nicely).

Updated

19 years ago
Assignee: trudelle → hyatt
Target Milestone: M9

Comment 1

19 years ago
reassigning to hyatt as p3 for M9. Dave, feel free to reassign to Linux folks
as appropriate.

Updated

19 years ago
Assignee: hyatt → pavlov

Comment 2

19 years ago
This is a dup of Pav's bug, namely that popups don't work at all on Linux.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

19 years ago
*** This bug has been marked as a duplicate of 8048 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

19 years ago
VERIFIED dupe
You need to log in before you can comment on or make changes to this bug.