Enhance Previous Searches

RESOLVED DUPLICATE of bug 1029848

Status

RESOLVED DUPLICATE of bug 1029848
5 years ago
4 years ago

People

(Reporter: MarcoM, Assigned: jboriss)

Tracking

(Blocks: 1 bug)

x86_64
All
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Details

(Whiteboard: [story] [search])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
1.  Goal:
* As a Firefox Desktop user I want to see my previous search history as clean visual suggestions to easily “re-query” or run that search again. 

2.  Acceptance Criteria (AC): 
* After a completed search the search terms used are easily the most visible item in the suggestion 
* Be a unified search history for searches from all SAPs (Search Access Points)

3.  Notes/Supporting Documentation: 
* Re-Query becomes very important tool for sync between devices [see data]
* Be a unified search history for searches from all SAPs (Search Access Points)
(Reporter)

Updated

5 years ago
Depends on: 958535
Created attachment 8359663 [details]
recent search terms in url bar.jpg
Depends on: 959580
Depends on: 959572
Depends on: 959582
Depends on: 959583
(Reporter)

Updated

5 years ago
Whiteboard: [story] → [story] [search]
(Reporter)

Updated

5 years ago
Blocks: 973272
(Reporter)

Updated

5 years ago
No longer depends on: 959572
(Reporter)

Updated

5 years ago
No longer depends on: 959580
(Reporter)

Updated

5 years ago
No longer blocks: 950073
Flags: firefox-backlog+
(Assignee)

Updated

4 years ago
Assignee: nobody → jboriss
(Assignee)

Updated

4 years ago
Depends on: 1029849
(Assignee)

Comment 2

4 years ago
Created attachment 8449915 [details]
Mockup: Current and proposed change to enhance previous searches in URL bar

Currently in Firefox, if a user performs a search through a search engine, the search results page enters their places database.  If the user enters a matching string to that results page in the URL bar, it appears as other URLS: a title at the top and a URL string at the bottom.

However, this search result is unlike other URLs.  Navigating to an old search effectively re-performs the search rather than goes to a destination.  This is not apparent in the interface.  Worse, the awesomebar suggestion contains a great deal of unneeded and useless information, such as the very long and unreadable search query URL.

A better design would highlight only the parts of the entry relevant to users: the term, the fact that it's a search, and the search engine.  Specifying that the search is from a user's history is not necessary, since it's within awesomebar results, and could potentially be embarrassing if noted explicitly.

The proposed design simplifies a re-search in awesomebar to the minimal elements meaningful to users: an icon to indicate search, a term, and the search engine.

Proposed changes:
1b. Replace favicon on search results with search magnifying glass icon in URL bar
2b. Remove URL for search results items in URL bar
3b. Remove the word "results" from results, (eg "Yahoo Search Results" would become "Yahoo Search")
(Assignee)

Comment 3

4 years ago
One note: Bryan's attachment 8359663 [details] shows a few stylistic changes in the URL bar.  While those are enhancements, they're out of scope for this particular bug, so simplifying visibility for only past searches is shown in attachment 8449915 [details]
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1029848
You need to log in before you can comment on or make changes to this bug.