my.yahoo doesn't serve tier1 on Firefox OS and Firefox Android

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: ndpaid, Assigned: karlcow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile-compat-form] [country-all] [serversniff] [sitewait], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Site: http://m.yahoo.com/w/myyahoo
The page is not displayed properly, and clicking on tabs doesn't work

:: Steps To Reproduce

1. Type "my.yahoo.com" in the address bar
2. If asked to, type in username and password for My yahoo account and log in.

:: Expected Result

The page should load normally (see https://support.cdn.mozilla.net/media/uploads/images/thumbnails/2014-01-08-09-32-28-aeed5b.png )

:: Actual Result

The page does not load normally, and clicking on tabs doesn't work either (see https://support.cdn.mozilla.net/media/uploads/images/thumbnails/2014-01-08-09-32-00-ea6a17.png )

:: Additional Information

Software Version: Firefox 26
Device Information: Samsung i-9300, Samsung P-3110, Samsung i-5800, a friend's LG G2
Reporter's User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
(Assignee)

Comment 1

4 years ago
The issue has a dependency on Bug 944512 (the login site). It is related to User Agent sniffing .
Assignee: nobody → kdubost
Status: UNCONFIRMED → ASSIGNED
Depends on: 944512
Ever confirmed: true
Hardware: Other → ARM
Summary: The page is not displayed properly, and clicking on tabs doesn't work → my.yahoo doesn't serve tier1 on Firefox OS and Firefox Android
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [country-all] [serversniff]
(Assignee)

Comment 2

4 years ago
On UcWeb, we get an ok site but with features not working.
The links in the top Tabs are working, but we can't slide tabs

On Firefox Android, we get a basic mobile site without rich graphics.

On Opera we get the same rich version than UCWeb, but surprisingly working better.
(Assignee)

Updated

4 years ago
Blocks: 993143

Comment 3

3 years ago
I just installed v32. my.yahoo.com is shown with all elements shown and tabs working fine, but it overflows the width of the screen horizontally, making it useless. It's displayed perfectly in both chrome and dolphin browsers.

Comment 4

3 years ago
Created attachment 8485490 [details]
my.yahoo under firefox 32 android

This is how the web site looks like in Firefox 32

Comment 5

3 years ago
Created attachment 8485491 [details]
my.yahoo under chrome

This is how it looks under chrome browser
(Assignee)

Comment 6

3 years ago
contactemail
Contacted Yahoo!
Whiteboard: [mobile-compat-form] [country-all] [serversniff] → [mobile-compat-form] [country-all] [serversniff] [sitewait]
(Assignee)

Comment 7

3 years ago
Yahoo! filed the bug.

> Filed internally at #7129580.
Automated test passes. Seems fixed indeed \o/
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.