Closed Bug 993143 Opened 6 years ago Closed 5 years ago

my.yahoo.com redirect loop in Firefox for Android

Categories

(Web Compatibility :: Mobile, defect)

All
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kbrosnan, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-all] [serversniff] [sitewait])

Loading my.yahoo.com results in a redirect loop.

GET my.yahoo.com           -> 302 m.yahoo.com/w/myyahoo
GET m.yahoo.com/w/myyahoo  -> 302 my.yahoo.com
GET my.yahoo.com           -> 302 m.yahoo.com/w/myyahoo
etc.
Assignee: nobody → kdubost
Depends on: 958924
Whiteboard: [country-all]
CONFIRMED on the command line. 
To be tested with and without login credentials.

→ http --print=Hh GET https://my.yahoo.com "User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0"

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: my.yahoo.com
User-Agent:  Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 302 Found
Age: 1
Cache-Control: private
Connection: keep-alive
Content-Type: text/html; charset=utf-8
Date: Tue, 08 Apr 2014 02:36:37 GMT
Location: http://m.yahoo.com/w/myyahoo
P3P: policyref="http://info.yahoo.com/w3c/p3p.xml", CP="CAO DSP COR CUR ADM DEV TAI PSA PSD IVAi IVDi CONi TELo OTPi OUR DELi SAMi OTRi UNRi PUBi IND PHY ONL UNI PUR FIN COM NAV INT DEM CNT STA POL HEA PRE LOC GOV"
Server: ATS
Set-Cookie: B=bmv7iit9k6o5l&b=3&s=2t; expires=Thu, 07-Apr-2016 02:36:37 GMT; path=/; domain=.yahoo.com
Transfer-Encoding: chunked
Vary: Accept-Encoding
Via: https/1.1 r07.ycpi.ir2.yahoo.net (ApacheTrafficServer/4.0.2 [cMsSf ])
X-Request-Info: bucket=999&device=featurephone&host=w9.my.bf1.yahoo.com&internal=1&intl=us&loggedin=0&pagetype=default&partner=default&product=my&protocol=https&requesttype=default&site=my&ua=FF%3A18%3AAndroid%3A+%3AMozilla&version=20140325


→ http --print=Hh GET https://m.yahoo.com/w/myyahoo "User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0"

GET /w/myyahoo HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.yahoo.com
User-Agent:  Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 302 Found
Age: 0
Cache-Control: no-store, private, no-transform
Connection: keep-alive
Content-Encoding: gzip
Content-Length: 119
Content-Type: text/html; charset=UTF-8
Date: Tue, 08 Apr 2014 02:37:05 GMT
Location: https://my.yahoo.com
P3P: policyref="http://info.yahoo.com/w3c/p3p.xml", CP="CAO DSP COR CUR ADM DEV TAI PSA PSD IVAi IVDi CONi TELo OTPi OUR DELi SAMi OTRi UNRi PUBi IND PHY ONL UNI PUR FIN COM NAV INT DEM CNT STA POL HEA PRE LOC GOV"
Server: ATS
Set-Cookie: YM=v=2&u=KVE1ROOosm2L6OFduzcgQZ5JtZL6nloJNdLOiA--&d=&f=AAA&t=RD2QTB&s=TVTE; expires=Fri, 08-Apr-2016 02:37:05 GMT; path=/; domain=.yahoo.com; HttpOnly
Set-Cookie: DK=v=2&p=OHw4MjQ0fFZpcnR1YWx8QW5kcm9pZHxBbmRyb2lkfA--; expires=Fri, 08-Apr-2016 02:37:05 GMT; path=/; domain=.yahoo.com
Set-Cookie: B=1pfvpflvvuo6h&b=3&s=q6; expires=Fri, 08-Apr-2016 02:37:05 GMT; path=/; domain=.yahoo.com
Vary: Accept-Encoding
Via: http/1.1 r05.ycpi.sp2.yahoo.net (ApacheTrafficServer/4.0.2 [cMsSf ])
x-frame-options: SAMEORIGIN


→ http --print=Hh GET https://my.yahoo.com "User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0"

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: my.yahoo.com
User-Agent:  Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 302 Found
Age: 0
Cache-Control: private
Connection: keep-alive
Content-Type: text/html; charset=utf-8
Date: Tue, 08 Apr 2014 02:37:30 GMT
Location: http://m.yahoo.com/w/myyahoo
P3P: policyref="http://info.yahoo.com/w3c/p3p.xml", CP="CAO DSP COR CUR ADM DEV TAI PSA PSD IVAi IVDi CONi TELo OTPi OUR DELi SAMi OTRi UNRi PUBi IND PHY ONL UNI PUR FIN COM NAV INT DEM CNT STA POL HEA PRE LOC GOV"
Server: ATS
Set-Cookie: B=9jg21fh9k6o7a&b=3&s=a7; expires=Thu, 07-Apr-2016 02:37:30 GMT; path=/; domain=.yahoo.com
Transfer-Encoding: chunked
Vary: Accept-Encoding
Via: https/1.1 r05.ycpi.sjb.yahoo.net (ApacheTrafficServer/4.0.2 [cMsSf ])
Whiteboard: [country-all] → [country-all] [serversniff] [contactready]
Contacted Yahoo! about it.
Status: NEW → ASSIGNED
Whiteboard: [country-all] [serversniff] [contactready] → [country-all] [serversniff] [sitewait]
Fixed! Thanks to Jenny at Yahoo!
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
I'm experiencing the same problem. I want to go to My.Yahoo, it gets redirected to yahoo.com I click on the menu and it goes to m.yahoo.com. I pick MY.yahoo and I get an error message 605. Website unresponsive. The problem happens everytime in Firefox, but not in Internet explorer. Ironically, I started having this problem on 8/8/14 and yours was fixed on 7/29/14. It seems to me your fix is what created my problem. I never had any problems before 8/8/14 getting to my.yahoo using Firefox. I reported my problem to Yahoo, and they refused to help, because I'm using an unsupported old version of Firefox. But it worked fine for me every day for a number of years. Can you please help me contact the right persons at Yahoo. Thanks.
pdwek, can you give more info so we can try to reproduce? Which platform and version? We probably want to open a new bug if it's not for Firefox for Android.
I'm running FireFox 2.0.11 on a Windows 98 system.
Here is the URL that is producing the error message :
>
>https://m.yahoo.com/w/myyahoo?.intl=us&.lang=en>
>and here is the copy of the error screen :
>
>My Yahoo!My Yahoo!
>Error encountered!
>Error encountered processing your last request!
>The website you are trying to access is not responding. Please try again later. (Error Code:605)
>All Yahoo! Sites
Mike,
I tried replying to your E-mail, but my response came back as undelivered. I just don't know how to properly communicate using this site. Anyway, I know I'm not entitled to any help from Mozilla or Yahoo, since I'm using such an old version, but since I have had no problems at all for many years until last week, I would like to be able to contact the person at Yahoo who wrote this fix. Could you give me please the Yahoo problem number, or the fix number for this BUG, so they will know what I'm talking about,hopefully ? I'm using an old desktop computer, but somehow Yahoo software thinks I'm using a mobile device, maybe this is why my link  to My.YAHOO is being redirected to m.yahoo ? I appreciate any help you can offer me. Thanks.
Flags: needinfo?(pdwek)
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.