Closed Bug 958994 Opened 7 years ago Closed 7 years ago

Switching from Desktop->Metro->Desktop tries to add tab with url: www.-desktop.com

Categories

(Firefox for Metro Graveyard :: General, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: capella, Unassigned)

References

Details

Start the FF for Win8 in Desktop, switch to the Metro UI, then relaunch back into desktop.

FF opens whatever tabs were open in Metro, then tries (and fails) to add/open a tab with the url: www.-desktop.com.

https://www.dropbox.com/s/swjgdwfbzy86bcq/switchMetroToDesktopAddsTab.png

I have addons (Chatzilla, AdBlock, and FlashVideoDownloader ... all are disabled.
Whiteboard: [triage]
Whiteboard: [triage] → [triage] [defect] p=0
Whiteboard: [triage] [defect] p=0 → [beta28] [defect] p=0
The "relaunch in desktop" code sends the special "http://-desktop" URI here:
http://hg.mozilla.org/mozilla-central/file/f356b409d710/widget/windows/winrt/MetroAppShell.cpp#l230

CommandExecuteHandler is supposed to catch this and not pass it to desktop:
http://hg.mozilla.org/mozilla-central/file/f356b409d710/browser/metro/shell/commandexecutehandler/CommandExecuteHandler.cpp#l600

I notice that the strings in these two files are slightly different.  One has a trailing slash and the other does not.  Mark, can you still reproduce this bug if you add the trailing slash to both strings?  (Or if you remove the slash from both strings?)
Flags: needinfo?(markcapella)
It seems to have cleared up while I was working over the weekend.

The only interesting thing I observed was that preceding the problems resolution, I had tried to launch a link from Thunderbird to explore triggering FF when in various run states/configurations (Metro, Desktop, Paused, etc)...

I was surpirsed by an OS request to make Aurora my default browser. I only had Nightly installed, but since Aurora was my only non-IE option in the dialogi-list, I selected it.

Up popped Metro! And now switching back/forth from Metro<-->Desktop has functioned fine since then.

Thanks for the attention! I'll keep my eye on it, and yell if something else goes wrong, but this is no longer an issue for me.
Flags: needinfo?(markcapella)
Removing from v1 tracking since this seems to be a hard-to-hit corner case.
No longer blocks: metrov1backlog
Whiteboard: [beta28] [defect] p=0 → [defect] p=0
See Also: → 960702
I'm going to chalk this up to gremlins.  We can reopen if it reappears.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
No longer blocks: metrobacklog
Whiteboard: [defect] p=0
You need to log in before you can comment on or make changes to this bug.