[Messages][MMS]The MMS body content is not shown in the thread list view

RESOLVED DUPLICATE of bug 1223432

Status

P2
normal
RESOLVED DUPLICATE of bug 1223432
5 years ago
3 years ago

People

(Reporter: oteo, Unassigned, Mentored)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-master affected)

Details

(Whiteboard: [lang=js][lang=css])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
The beginning of the body content of a sent, received or draft MMS is not shown in the thread list view.

When MMS was implemented it seems that was not possible to show it due to any technical issue. It is still outstanding for the Interaction team (SMS shows it the body content) so let's open this bug to track it and try to fix it as soon as it can be possible.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 1.4?
(Reporter)

Comment 1

5 years ago
Julien, right now, are there any technical impediment to implement this for 1.4?
Flags: needinfo?(felash)
If we have the MMS content (ie: it was downloaded) then there is no problem to display any text content. We only need UX Design (to resolve issues like what do to when there is no text content, when there is both subject and body, when the MMS is not downloaded, etc) and visual design (do we still have the "MMS" badge in the thread list ? things like that).

That said, I'd rather see this in the "targeted" list than the "blocking" list.
Flags: needinfo?(felash)
Triage: pending feature to be implemented, adding it to backlog to be considered in the next release (some gecko work seems to be needed too)
blocking-b2g: 1.4? → backlog
Omega, can you provide some UX guidance here? Then I could make this bug a mentored bug.
Flags: needinfo?(ofeng)
Here are the rules:

Not downloaded:
    MMS

Downloaded:

  With Subject & Body:
    MMS %Subject - %Body

  With Subject, no Body:
    MMS %Subject

  No Subject, with Body:
    MMS %Body

  No Subject, no Body:
    MMS

If %Subject/%Body is too long, use ... and the end. (max 1 row)
For colors, "MMS" is orange, and %Subject/%Body is gray.
Flags: needinfo?(ofeng)
Whiteboard: [mentor=:julienw][lang=javascript][lang=css]
Whiteboard: [mentor=:julienw][lang=javascript][lang=css] → [mentor=:julienw][lang=js][lang=css]
(Assignee)

Updated

5 years ago
Mentor: felash
Whiteboard: [mentor=:julienw][lang=js][lang=css] → [lang=js][lang=css]
Mentor: felash
Duplicate of this bug: 1047899

Comment 7

4 years ago
Would it be possible to show a small thumbnail of the MMS body's attached image as well as text?
I think it would clutter the display...

Comment 9

4 years ago
(In reply to Julien Wajsberg [:julienw] from comment #8)
> I think it would clutter the display...

Eh. At the resolution it would have to be at to fit the line, I think it'd not be terribly distracting. I'd like to try it out at least.
(Assignee)

Updated

4 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
qawanted to check if it still happens on master.
Keywords: qawanted
Created attachment 8594059 [details]
screenshot of issue on Flame 3.0

This issue is reproducible on Flame 3.0. The MMS content that I created is just a subject line and a body, I didn't attach any pictures. See screenshot.

Device: Flame 3.0 Master (full flashed 319MB mem KK)
BuildID: 20150417010203
Gaia: 3cd0a9facce26c2acc7be3755a17131a6358e33f
Gecko: 51e3cb11a258
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: qawanted
Mentor: felash
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Priority: -- → P2
To be efficient
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1223432
You need to log in before you can comment on or make changes to this bug.