One character missing when doing netscape search from url bar

VERIFIED DUPLICATE of bug 94727

Status

VERIFIED DUPLICATE of bug 94727
17 years ago
10 years ago

People

(Reporter: neutropenia, Assigned: alecf)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Win98Se, moz build 2001081703

Reproducible : Always
Steps
1. Write a search term in the URL bar, suppose you type "browser"
2. Look in the drop-down menu for : Search Netscape Search for "browse"
3. The last character of the word browser is missing.
4. Also note that we could use "Netscape search " instead of "Search Netscape
Search". 

Actual result : The last character of the search sentence is missing (also
occuring with multiple word searches

Expected result : All characters typed showing up in the URL bar drop down.

Additional info :
In order to have the last character displaying, you can type any other character
after your search terms. Try it. Suppose I type the word "food" in the URL bar,
only "foo" is showing up. I add the letter "x" so I wrote "foodx" but only food
is showing up, which is what I want. Now press backspace to delete the "x" and
it appears in the drop down, even though only "food" appears in  the URL bar.
Seems like the synchronization between what is typed in the URL bar and what
appears in the search drop down is one character behind. If this isn't too
clear, try it, you will quickly see what I meant.

Comment 1

17 years ago
Confirming with the same build under Win2k. Leaving OS at Win98 since I don't
know if it also affects *nix or mac.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 94727 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
v.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.