[MADAI][Camera] Camera application should handle low battery scenario

RESOLVED DUPLICATE of bug 966841

Status

Firefox OS
Gaia::Camera
--
major
RESOLVED DUPLICATE of bug 966841
4 years ago
4 years ago

People

(Reporter: Sharaf, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Camera application should handle low battery scenarios as explained below

1. When the camera application is in foreground and the battery level reaches <15% then
	* A popup should be shown

2. When the camera application is in foreground and the battery level reaches <5% then
	* A popup should be shown "Battery too low"

3. User tries to launch the application and the battery level is <5%
	* A popup should be shown "Battery too low" and the app should not be launched.
(Reporter)

Updated

4 years ago
Blocks: 959511
Created attachment 8368514 [details] [review]
pull-request (master)
Attachment #8368514 - Flags: review?(dmarcos)
I've submitted a PR to kick start this issue. It confirms the the above spec, providing app events that UI can hook into.

Possible battery status:

- 'healthy'
- 'low'
- 'critical'

Available event hooks:

app.on('change:battery', function(status) {...});
app.on('battery:healthy', function() {...});
app.on('battery:low', function() {...});
app.on('battery:critical', function() {...});
Hi Rob,
Can you chime in on the UX here?
Flags: needinfo?(rmacdonald)
We have a proposal that we'll be updating early next week based on partner feedback. It's consistent with Sharaf's description with the exception that we show a prompt at 6% before the Camera is blocked and that we include a low battery indicator in the viewfinder to alert the user. The indicator changes in appearance at 6% to warn the user that the battery is a critical levels. NI me if you want a draft copy. Otherwise I will be posting the specs late next week.
Flags: needinfo?(rmacdonald)
Rob,

Do we have updates here to move this forward?
Flags: needinfo?(rmacdonald)
Hi Wayne...

Yes, the flows are included in the UI spec, which is attached to bug 971444. The visual specs for this feature are attached to bug 973669.

I should also add that the reason we agreed to disable the camera in low battery scenarios is due to the risk that video recording will not be saved properly and the user could lose their data. Otherwise we don't believe phone features should be blocked in low battery scenarios.

Thanks!
Rob
Flags: needinfo?(rmacdonald)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 966841
Attachment #8368514 - Flags: review?(dmarcos)
You need to log in before you can comment on or make changes to this bug.