Closed Bug 966841 Opened 6 years ago Closed 6 years ago

[User story] Battery status while taking pictures or recording a video

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: skasetti, Assigned: singhashish1887)

References

Details

(Whiteboard: [fxos:media])

User Story

1. As a user, while using camera if the phone's battery is at 15% or 10%  I want a visual warning indicating that the battery status is low so that I can charge the phone 
2. As a user, while using camera if the phone's battery is at 15% or 10%  I want to see a persistent visual indicator that the battery status is low 
3. As a user, while using camera if the phone's battery is at 6% the low battery
icon should pulse fading out and back in again every two seconds
4. As a user, while using camera if the phone's battery is at or below 5% I can no longer use the camera and I want to see a confirmation message indicating such a warning
5. As a user, while using camera if the phone's battery is at or below 5% I want the photo or video file to be saved so that file doesn't get corrupted
No description provided.
User Story: (updated)
Ashish! Please check the user stories and update the current status.
Assignee: nobody → singhashish1887
Display of battery status indicator is done.
Display of battery status indicator is done. With help of navigator battery API .
Blocks: 966764
singhashish1887: Do you have a patch for review? 

Thanks!
Hema
Flags: needinfo?(singhashish1887)
This bug is same as https://bugzilla.mozilla.org/show_bug.cgi?id=948263. 
Ashish already uploaded our patch.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 948263
Flags: needinfo?(singhashish1887)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Depends on: 948263
Duplicate of this bug: 959515
Depends on: 982054
Bug-948263 and 982054 are fixed. So I close this issue.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
blocking-b2g: --- → 1.4+
Removing the 1.4+ flag, since this is a meta bug and there aren't any patches here that need uplift.
blocking-b2g: 1.4+ → ---
You need to log in before you can comment on or make changes to this bug.