JavaScript Warning: "Unknown property 'box-sizing'. Declaration dropped." {file: "resource://gre-resources/html.css"

RESOLVED FIXED in Firefox 29, Firefox OS v1.4

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gkw, Assigned: alive)

Tracking

unspecified
1.3 C2/1.4 S2(17jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(firefox29 fixed, b2g-v1.4 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 8360222 [details]
sample adb logcat output

+++ This bug was initially created as a clone of Bug #959936 +++

E/GeckoConsole(   44): [JavaScript Warning: "Unknown property 'box-sizing'.  Declaration dropped." {file: "resource://gre-resources/html.css" line: 733 column: 12 source: "  box-sizing: border-box;"}]

This happens on first-run startup of the emulator, tested with the jb version of the emulator in pvt builds, with timestamp 20140114154437.

Alive, any idea what this might be related to?
Flags: needinfo?(alive)
Component: Gaia → General
Flags: needinfo?(alive)
(Reporter)

Comment 2

5 years ago
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #1)
> Root cause:
> http://mxr.mozilla.org/mozilla-central/source/layout/style/html.css#733

Thanks Alive! This points to bug 865407 or http://hg.mozilla.org/mozilla-central/rev/9264d50055ea as the possible cause.

Thoughts, bz? (you might want to adjust the product/component)
Flags: needinfo?(bzbarsky)
Created attachment 8360301 [details] [diff] [review]
fix-959945.diff

One line fix to remove warning of box-sizing
Attachment #8360301 - Flags: review?(bzbarsky)

Comment 4

5 years ago
Agh. For some reason I thought I had read on MDN that this wasn't prefixed in FF.
Comment on attachment 8360301 [details] [diff] [review]
fix-959945.diff

r=me
Attachment #8360301 - Flags: review?(bzbarsky) → review+
Flags: needinfo?(bzbarsky)
Created attachment 8360803 [details] [diff] [review]
bug-959945-checkin.patch

checkin
Attachment #8360301 - Attachment is obsolete: true
Keywords: checkin-needed
(Reporter)

Updated

5 years ago
status-b2g-v1.4: --- → affected
status-firefox29: --- → affected
https://hg.mozilla.org/integration/fx-team/rev/0513569bea2c
Assignee: nobody → alive
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0513569bea2c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
(Reporter)

Comment 9

5 years ago
Fixed on m-c, setting status flags as appropriate.
status-b2g-v1.4: affected → fixed
status-firefox29: affected → fixed
You need to log in before you can comment on or make changes to this bug.