JavaScript Warning: "Unknown property 'user-select'. Declaration dropped." {file: "app://communications.gaiamobile.org/ftu/css/style.css"

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::First Time Experience
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: gkw, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v1.4 affected)

Details

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #959936 +++

E/GeckoConsole(  363): [JavaScript Warning: "Unknown property 'user-select'.  Declaration dropped." {file: "app://communications.gaiamobile.org/ftu/css/style.css" line: 9 column: 13 source: "  user-select: none;"}]

This happens on first-run startup of the emulator, tested with the jb version of the emulator in pvt builds, with timestamp 20140114154437.

https://github.com/mozilla-b2g/gaia/blame/79a50a1aacad3587758f7dd6cc7e27bdbd3410e5/apps/communications/ftu/css/style.css#L9

This line was changed in:

https://github.com/mozilla-b2g/gaia/commit/1e168bed75e50accc7b7b346e4a6e5f07282ed38

via bug 813227, so setting needinfo? from Fernando.
Flags: needinfo?(fernando.campo)
(Reporter)

Updated

4 years ago
status-b2g-v1.4: --- → affected
Keywords: regression
The line was there since the creation of the file [https://github.com/mozilla-b2g/gaia/commit/603575be5d862abdf8ce8c5dfb2173541f825964#diff-7b8796a21da5680ddb7673eca0d52c5cR10] but my guess is that is not needed at all, as we don't have text selection implemented yet.

Or, we could use it with the prefix -moz-user-select, as the basic rule is not supported.
Flags: needinfo?(fernando.campo)
(Reporter)

Comment 2

4 years ago
(In reply to Fernando Campo (:fcampo) from comment #1)
> The line was there since the creation of the file

Not a regression then.


> but my guess is that is not needed at
> all, as we don't have text selection implemented yet.
> 
> Or, we could use it with the prefix -moz-user-select, as the basic rule is
> not supported.

Not sure if this is the appropriate way forward. Tim, what do we prefer?
Flags: needinfo?(timdream)
Keywords: regression
We should remove what's Gecko is not supported for now and add them back later.
Flags: needinfo?(timdream)
(Reporter)

Comment 4

4 years ago
I no longer see JavaScript warnings when launching FTE. (Tested via launching First-Time Experience via the Developer menu)

Tested with the Flame on:

$ ./check_versions.sh
Gaia      0f9f11d0a6dadb3ea27160204bbe911c1ad69a6f
Gecko     https://hg.mozilla.org/mozilla-central/rev/196d05832e12
BuildID   20140709040203
Version   33.0a1
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.