JavaScript Warning: "Unknown property 'will-change'. Declaration dropped." {file: "app://settings.gaiamobile.org/style/settings.css"

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gkw, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v1.4 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #959936 +++

E/GeckoConsole(  529): [JavaScript Warning: "Unknown property 'will-change'.  Declaration dropped." {file: "app://settings.gaiamobile.org/style/settings.css" line: 71 column: 13 source: "  will-change: scroll-position;"}]

This happens after starting up the emulator, tested with the jb version of the emulator in pvt builds, with timestamp 20140114154437, then launching the Settings app.

https://github.com/mozilla-b2g/gaia/blame/4cc2dcbf9cebf6d4731783626acf57c3e712f479/apps/settings/style/settings.css#L71

This line was changed in:

https://github.com/mozilla-b2g/gaia/commit/c6ab2ccd2bd7ee5ffb604a051db890a729f5aa13

via bug 950498, so setting needinfo? from Mason.
Flags: needinfo?(mchang)
(Reporter)

Comment 1

4 years ago
FWIW, launching the Contacts app will also result in:

E/GeckoConsole(  642): [JavaScript Warning: "Unknown property 'will-change'.  Declaration dropped." {file: "app://communications.gaiamobile.org/contacts/style/app.css" line: 349 column: 13 source: "  will-change: scroll-position;"}]
E/GeckoConsole(  642): [JavaScript Warning: "Unknown property 'will-change'.  Declaration dropped." {file: "app://communications.gaiamobile.org/contacts/style/contacts.css" line: 41 column: 13 source: "  will-change: scroll-position;"}]

For now, I'm assuming they're related, because the following commit:

https://github.com/mozilla-b2g/gaia/blame/4cc2dcbf9cebf6d4731783626acf57c3e712f479/apps/communications/contacts/style/app.css#L349

seems to also point to bug 950498.
Yes, we're still waiting on bug 940842 to land, which will enable support for this in Gecko. This is expected behavior until it lands properly in Gecko.
Flags: needinfo?(mchang)
(Reporter)

Updated

4 years ago
status-b2g-v1.4: --- → affected
Keywords: regression
(Reporter)

Comment 3

4 years ago
I no longer see JavaScript warnings when launching the Settings app.

Tested with the Flame on:

$ ./check_versions.sh
Gaia      0f9f11d0a6dadb3ea27160204bbe911c1ad69a6f
Gecko     https://hg.mozilla.org/mozilla-central/rev/196d05832e12
BuildID   20140709040203
Version   33.0a1
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

Assuming fixed by bug 940842 which landed for Gecko 29, i.e. FxOS 1.4 and later should have this fix.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v1.4: affected → fixed
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.