JavaScript Error: "TypeError: thumbnailList is undefined" {file: "app://video.gaiamobile.org/gaia_build_defer_index.js"

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gkw, Assigned: vsireesha246)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
E/GeckoConsole(  613): [JavaScript Error: "TypeError: thumbnailList is undefined" {file: "app://video.gaiamobile.org/gaia_build_defer_index.js" line: 525}]

This happens after starting up the emulator, tested with the jb version of the emulator in pvt builds, with timestamp 20140114154437, then launching the Videos app.

Not sure how to move this forward, setting needinfo? from David, the Gaia::Video module owner.
Flags: needinfo?(dflanagan)
I know what's going on. We used the screenlayoutchange event to do some UI updates instead of resize event because there is multiple resize events in firefox nightly when we rotate the simulator. After APZ is enabled by default, the sequence of screenlayoutchange is different than before.

At first, we don't have screenlayoutchange event at the app start-up. So, we may add some code to check if it is under start-up procedure to prevent that or to use resize event but need to check the rotation issue of simulator.
Flags: needinfo?(dflanagan)
The screenlayoutchange event is built from the change event of MediaQueryListListener. I should mention it in comment 1.
(Reporter)

Updated

5 years ago
status-b2g-v1.4: --- → affected
Assignee: nobody → vsireesha246
(Assignee)

Comment 3

5 years ago
Created attachment 8362400 [details]
Pointer to Pull Request.html

Hi John,

I added the check condition as per our discussion in IRC.
Please review and let me know the review comments.

Thanks,
Sireesha.
Attachment #8362400 - Flags: review?(johu)
Comment on attachment 8362400 [details]
Pointer to Pull Request.html

Thanks for this patch.

I had filed a bug 961636 to address the additional resize events while app starts up. That's the root cause of this bug. But I would like to land the this workaround patch to get rid of ugly error log.
Attachment #8362400 - Flags: review?(johu) → review+
merged to master:
https://github.com/mozilla-b2g/gaia/commit/7bd157d797cca114c51401170ca1c8d366be9551
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.