Closed Bug 960120 Opened 10 years ago Closed 10 years ago

[APZC] Can not scroll contacts tab of Dialer app

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: vingtetun, Assigned: vingtetun)

References

Details

Attachments

(1 file)

Step to reproduce:
 - Open the dialer app
 - Open the Contacts tab, try to scroll it. It works
 - Open the call log, try to scroll it. It works
 - Open the Contacts tab, try to scroll it. It does not work.

Seems like the same root issue than usual. visibility: hidden is not ignored correctly.
Attached patch bug960120.patchSplinter Review
Let's move the z-index since it seems weird that the z-index of the hidden element is bigger than the one of the displayed element.
Attachment #8360482 - Flags: review?(arnau)
Comment on attachment 8360482 [details] [diff] [review]
bug960120.patch

Works great in all apps with tabs, thanks!
Attachment #8360482 - Flags: review?(arnau) → review+
Assignee: nobody → 21
blocking-b2g: --- → 1.3+
I was not able to uplift this bug to v1.3.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.3, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.3
  git cherry-pick -x -m1 eec6ab24d922531a8d53f22e0d974c8620f7c051
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(21)
My bad. Looking at the code this issue should not reproduce on 1.3.
blocking-b2g: 1.3+ → ---
Flags: needinfo?(21)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: