switching away from Fennec and then back causes Marketplace content to disappear

VERIFIED FIXED in 2014-02-18

Status

Marketplace
General
P1
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: myk, Assigned: ngoke)

Tracking

({reproducible})

2014-02-18
ARM
Android
reproducible
Points:
---

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8360598 [details]
screenshot showing page after returning to Fennec

After loading marketplace.firefox.com in Fennec, if I press the Android device's Home button to go to the homescreen and then return to Fennec, then Marketplace's content disappears and is replaced by a blank gray background with a little bit of Marketplace navigation at the top (specifically: the search bar and the categories bar).

I see this with the latest Fennec nightly as well as older Fennec nightlies (and various custom builds I've produced).  It isn't clear whether it's a Fennec draw/paint bug or a Marketplace bug (f.e. a reaction to some event like pageshow that fires when I return to Fennec), but I'm filing it in the Marketplace product for now with some Fennec hackers cc:ed.

The bug is particularly noticeable on Fennec builds that have synthetic APKs enabled, since the synthetic APK install process switches away from Marketplace to a native Android "confirm install" dialog, and the bug occurs when you switch back.

But it happens even with synthetic APKs disabled, and it happens on builds from before I landed support for synthetic APKs last week, so it is *not related* to synthetic APKs.

Updated

4 years ago
Duplicate of this bug: 959542

Comment 2

4 years ago
Starting with Synthetic APKs this got worse as you can see it more often:

Steps:
1. Install any app 
2. After the installation success screen (Open/Done buttons screen) press back to get back in Fennec

The marketplace will be blank. A refresh page is needed.
Severity: normal → major
Priority: -- → P1
Target Milestone: --- → 2014-02-04

Updated

4 years ago
Blocks: 968380

Updated

4 years ago
Duplicate of this bug: 968964

Updated

4 years ago
Keywords: reproducible

Comment 4

4 years ago
This got bumped to P1 and a target milestone added by cvan, but no-one took it work on it. Would someone be able to do that?

Comment 5

4 years ago
Sometimes the categories landing page is also blank upon loading.
(Assignee)

Comment 6

4 years ago
I ran into the cause.
Assignee: nobody → kngo
(Assignee)

Updated

4 years ago
Duplicate of this bug: 970704
(Assignee)

Comment 8

4 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=917592

Regressed due to the fix that allows the Install/Launch to refresh state after a user installs/deletes an app. Fireplace rebuilds the page every time the user navigates away and back (via tab switch or app window change), but doesn't re-fetch deferred content.

The behavior should change to only rebuild the install button rather than rebuild the whole page on visibility change.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 970641
(Assignee)

Comment 10

4 years ago
https://github.com/mozilla/fireplace/pull/367/

Relevant STRs:

https://bugzilla.mozilla.org/show_bug.cgi?id=970641

https://bugzilla.mozilla.org/show_bug.cgi?id=917592
Target Milestone: 2014-02-04 → 2014-02-18
(Assignee)

Updated

4 years ago
Duplicate of this bug: 971193
(Assignee)

Comment 12

4 years ago
https://github.com/mozilla/fireplace/pull/367
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 13

4 years ago
Created attachment 8375138 [details]
screenshot

STR:
1. Load https://marketplace-dev.allizom.org on firefox mobile
2. Load the app details page 
3. Hit Back button to load the homepage 

observed behavior:
Homepage is blank upon loading

ashes: 4128c

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 14

4 years ago
(In reply to krupa raj[:krupa] from comment #13)
> Created attachment 8375138 [details]
> screenshot
> 
> STR:
> 1. Load https://marketplace-dev.allizom.org on firefox mobile
> 2. Load the app details page 
> 3. Hit Back button to load the homepage 
> 
> observed behavior:
> Homepage is blank upon loading
> 
> ashes: 4128c

Note that I had to browse around for a while before I hit this issue.
(Assignee)

Comment 15

4 years ago
Is that related to this bug? Marketplace seems to be having numerous issues on Firefox Mobile for Android.

Comment 16

4 years ago
I filed https://bugzilla.mozilla.org/show_bug.cgi?id=972068
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Comment 17

4 years ago
I was not able to reproduce the issues described in original scenario or comment #2 .
Ioana , can you please confirm that the issue is not reproducible anymore in order to close the bug?
Flags: needinfo?(chiorean.ioana)
Yes, the issue is not reproducible on latest Nightly 02/14 using LG Nexus 4 (Android 4.4.2) with different apps installed.
Flags: needinfo?(chiorean.ioana)

Comment 19

4 years ago
Thank you Teodora!
Verified as fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.