Re-enable test: test_persona_cookie.py test_persona_cookie.TestPersonaCookie.test_persona_cookie

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kgrandon, Assigned: AndreiH)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
test_persona_cookie (test_persona_cookie.TestPersonaCookie) ... ERROR

======================================================================

ERROR: None

----------------------------------------------------------------------

Traceback (most recent call last):

File "/home/travis/build/mozilla-b2g/gaia/travis_venv/local/lib/python2.7/site-packages/marionette_client-0.7.2-py2.7.egg/marionette/marionette_test.py", line 143, in run

testMethod()

File "/home/travis/build/mozilla-b2g/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/persona/test_persona_cookie.py", line 39, in test_persona_cookie

self.wait_for_element_displayed(*self._logged_out_button_locator, timeout=120)

File "/home/travis/build/mozilla-b2g/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 1034, in wait_for_element_displayed

raise TimeoutException('Element %s present but not displayed before timeout' % locator)

TEST-UNEXPECTED-FAIL | test_persona_cookie.py test_persona_cookie.TestPersonaCookie.test_persona_cookie | TimeoutException: Element #signinhere .btn-persona present but not displayed before timeout

----------------------------------------------------------------------

Ran 1 test in 160.565s

FAILED (errors=1)
(Reporter)

Comment 1

5 years ago
Zac - this test was disabled for intermittent failures in: https://github.com/KevinGrandon/gaia/commit/cd728253dc51cad672a4860d3599df235f54631b

Potentially related to bug 956165? Ni? so you are aware.
Flags: needinfo?(zcampbell)
See Also: → bug 938657

Comment 2

5 years ago
Thanks Kevin, it was quite stable but seems to have flared up again. we'll look into it again.
Flags: needinfo?(zcampbell)
Assignee: nobody → andrei.hutusoru
(Assignee)

Comment 3

5 years ago
Tried to run both tests on Travis with repeat 100 but Travis is configured to timeout after 50 minutes
The run got to repeat= 26. I will skip the second test 
https://travis-ci.org/mozilla-b2g/gaia/jobs/17340169
(Assignee)

Comment 4

5 years ago
Run test_persona_cookie.py on Travis with repeat 100, sadly got only to repeat 41 and the successfully passed [1].
I will start testing this locally to reach 100 runs using the Travis scripts, and then report back.

Here is the run on Travis:

[1] https://travis-ci.org/mozilla-b2g/gaia/jobs/17346021
(Assignee)

Comment 5

5 years ago
I ran this test locally using the Travis scripts, repeat over 100. I Search Results accidentally stopped the first run at repeat 36, and restarted the runs again with a repeat of 75 times. Could not reproduce the fail. From my part, we can re-enable the coverage for this test.

Here are the results locally:
https://pastebin.mozilla.org/4073250

Comment 6

5 years ago
Let's aim to re-enable this coverage.

What we need to do is run it on Travis with --repeat to assert the stability.
Priority: -- → P1
Summary: Intermittent failing test: test_persona_cookie.py test_persona_cookie.TestPersonaCookie.test_persona_cookie → Re-enable test: test_persona_cookie.py test_persona_cookie.TestPersonaCookie.test_persona_cookie

Comment 7

5 years ago
Oops I mis-read Andrei's comment!

Let's re-enable this straight away then :)
(Assignee)

Comment 8

5 years ago
Created attachment 8365863 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/15715
Attachment #8365863 - Flags: review?(zcampbell)
Attachment #8365863 - Flags: review?(florin.strugariu)

Comment 9

5 years ago
Comment on attachment 8365863 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/15715

r-, this is failing because of https://bugzilla.mozilla.org/show_bug.cgi?id=963582

We can change it to expected = fail
Attachment #8365863 - Flags: review?(zcampbell)
Attachment #8365863 - Flags: review?(florin.strugariu)
Attachment #8365863 - Flags: review-
(Assignee)

Comment 10

5 years ago
Comment on attachment 8365863 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/15715

Updated the manifest
Attachment #8365863 - Flags: review- → review?(zcampbell)
(Assignee)

Updated

5 years ago
Attachment #8365863 - Flags: review?(florin.strugariu)
Attachment #8365863 - Flags: review?(florin.strugariu) → review+

Updated

5 years ago
Attachment #8365863 - Flags: review?(zcampbell)

Comment 12

5 years ago
Re-enabled proper:
https://github.com/mozilla-b2g/gaia/commit/0783aa5a417e404f5d2034f236137a1582580c7f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.