If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Create base FTE Integration tests

RESOLVED FIXED in 1.3 C3/1.4 S3(31jan)

Status

Firefox OS
Gaia::First Time Experience
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: qdot, Assigned: qdot)

Tracking

unspecified
1.3 C3/1.4 S3(31jan)
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ucid:browser104] [systemsfe] [1.4:p2])

Attachments

(1 attachment, 1 obsolete attachment)

We should have a few integration tests to make sure the app comes up when it's supposed to, that everything can be clicked through, and that the recent wifi scanning lockup stays fixed.
Created attachment 8360831 [details] [diff] [review]
Patch 1 (v1) - WIP: Add basic tests to FTE

This is currently blocked on mobileConnection detection issues which means it will fail travis every time (Bug 951888). Would like to get fb going though so maybe we can get a quick r when it's ready.
Attachment #8360831 - Flags: feedback?(mhenretty)
Attachment #8360831 - Flags: feedback?(francisco.jordano)
Blocking on mobileConnection issues in system app
Depends on: 951888
Looking pretty good!

Thanks Kyle, again looking pretty promise, should we have one simple to go through the tutorial?
Comment on attachment 8360831 [details] [diff] [review]
Patch 1 (v1) - WIP: Add basic tests to FTE

Dough!

Forgot to add the f+ :)
Attachment #8360831 - Flags: feedback?(francisco.jordano) → feedback+
Created attachment 8361250 [details] [review]
Patch 1 (v2) - Add basic tests to FTE

Airplane mode patch that at least lets this run landed. Also implemented feedback from :arcturus
Attachment #8360831 - Attachment is obsolete: true
Attachment #8360831 - Flags: feedback?(mhenretty)
Attachment #8361250 - Flags: review?(mhenretty)
Attachment #8361250 - Flags: review?(francisco.jordano)
Comment on attachment 8361250 [details] [review]
Patch 1 (v2) - Add basic tests to FTE

Thanks for adding these, we needed it. I left some comments on the PR about using the marionette helper more (and maybe adding to it!). Overall, these look good, and its a nice API for going through the steps.
Attachment #8361250 - Flags: review?(mhenretty) → review+
Comment on attachment 8361250 [details] [review]
Patch 1 (v2) - Add basic tests to FTE

Awesome work, first steps looking promise \o/

Thanks a lot Kyle!
Attachment #8361250 - Flags: review?(francisco.jordano) → review+
https://github.com/qdot/gaia/commit/c6f5d1b8c5ca3c4bdd240c729e1a04e6820e1865
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [ucid:browser104] [systemsfe] [1.4:p2]
Duplicate of this bug: 951927
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
You need to log in before you can comment on or make changes to this bug.