All users were logged out of Bugzilla on October 13th, 2018

[DSDS] Enable or disable data roaming on SIM 1 will also do the same on SIM 2, vice versa.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: echu, Unassigned)

Tracking

unspecified
x86_64
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(tracking-b2g:+)

Details

(Whiteboard: dsdsrun1.3-2)

(Reporter)

Description

5 years ago
I will use this bug to track all similar problems found in Cellular & Data settings.

1. Check SIM 1 Carrier first, then go to SIM 2, you'll first see SIM 1 carrier first then changed to SIM 2.
2. If SIM 1 is primary outgoing data, enable or disable data call on SIM 1 will also set on SIM 2, and vice versa.
3. Enable or disable data roaming on SIM 1 will also do the same on SIM 2, vice versa.
4. Enable or disable automatic selection on SIM 1 will also do the same on SIM 2, vice versa.

Above are some examples, please make sure SIM 1 and SIM 2 Cellular & Data settings are totally independent. 

* Build Number  
Fugu              
Gaia      a119a0692c24c5ed7c55bab838bae3ecdb9dbec9
Gecko     15ee4e78431b45922b41dea882464b0ccb6b4fac
BuildID   20140110174141
Version   28.0a2

* Occurrence rate
100%
(In reply to Enpei from comment #0)
> I will use this bug to track all similar problems found in Cellular & Data
> settings.
> 
> 1. Check SIM 1 Carrier first, then go to SIM 2, you'll first see SIM 1
> carrier first then changed to SIM 2.
> 2. If SIM 1 is primary outgoing data, enable or disable data call on SIM 1
> will also set on SIM 2, and vice versa.

This isn't a bug I think. As we only allow one data connection at a time, we need a global value to represent whether data is enabled or not. If SIM 1 is set for primary outgoing data, from SIM2 menu we see corresponding changes set to SIM1, but user cannot change the value from SIM2 menu.

If the UI is confusing, then we might need UX help to improve it.

> 3. Enable or disable data roaming on SIM 1 will also do the same on SIM 2,
> vice versa.

Indeed a bug unless our UX doesn't want our user to have a chance to set it separately.

> 4. Enable or disable automatic selection on SIM 1 will also do the same on
> SIM 2, vice versa.
> 

Same as 3.

> Above are some examples, please make sure SIM 1 and SIM 2 Cellular & Data
> settings are totally independent. 
> 
> * Build Number  
> Fugu              
> Gaia      a119a0692c24c5ed7c55bab838bae3ecdb9dbec9
> Gecko     15ee4e78431b45922b41dea882464b0ccb6b4fac
> BuildID   20140110174141
> Version   28.0a2
> 
> * Occurrence rate
> 100%
Component: RIL → Gaia::Settings
(Reporter)

Comment 2

5 years ago
After discuss with Hsinyi and Arthur, this bug will be tracked for following items only:

1. Enable or disable data roaming on SIM 1 will also do the same on SIM 2, vice versa.
2. Enable or disable automatic selection on SIM 1 will also do the same on SIM 2, vice versa.
3. When switch SIM 1 either data/message/A-GPS APN setting, i.e. select 2nd item in data apn setting, SIM 2 data setting will be set to "custom", vice versa.
(In reply to Enpei from comment #0)

> 1. Check SIM 1 Carrier first, then go to SIM 2, you'll first see SIM 1
> carrier first then changed to SIM 2.

The panel needs to be refreshed when switching between ICC cards and it takes time. The UX for cellular and data settings for multi ICC card devices leads to this UX. At the end the panel is updated correctly and it shows the information from the ICC card so this is not a bug IMHO. If the UX needs to be re-designed please flag UX people.

> 2. If SIM 1 is primary outgoing data, enable or disable data call on SIM 1
> will also set on SIM 2, and vice versa.

Yes, set the same value but the switch button is disabled as UX designed it. If the UX needs to be re-designed please flag UX people.

> 3. Enable or disable data roaming on SIM 1 will also do the same on SIM 2,
> vice versa.

Yes, the switch button is not disabled here, this is how UX designed it. 

> 4. Enable or disable automatic selection on SIM 1 will also do the same on
> SIM 2, vice versa.

I would need to check what is going on here. I'll take a look.
(Reporter)

Comment 4

5 years ago
Hi José,

I've changed bug description to comment 2, which you have answered item 1 and 2 in comment 2. 

>> 1. Enable or disable data roaming on SIM 1 will also do the same on SIM 2,
>> vice versa.
>Yes, the switch button is not disabled here, this is how UX designed it. 
What do you mean by it's UX design? When SIM 1 data roaming is set to on, SIM 2 will be on as well, but it's not quite right. We don't know if user will insert roaming SIM on both SIM cards or not, if one caused higher rate is automatically roaming on, this will cause problem. We should let user to decide that.
(In reply to Enpei from comment #4)
> >Yes, the switch button is not disabled here, this is how UX designed it. 

> What do you mean by it's UX design? When SIM 1 data roaming is set to on,
> SIM 2 will be on as well, but it's not quite right.

No, it isn't. You're right. What I mean is that UX didn't suggest to disabled the switch button for roaming setting in the panel for the ICC card which is not active for data calls. So this is the reason the button is enabled and the user might change the setting. This is wrong and we should change and disable the switch button as we do with the data calls enabled one.
Clearing nom - we need each problem raised here in a separate bug to triage this.

Enpei - Can you split each problem into a separate bug?
blocking-b2g: 1.3? → ---
Flags: needinfo?(echu)
(Reporter)

Comment 7

5 years ago
Hi Arthur,

Do you think I still need to split these items into different bugs? Just don't want to be set duplicate afterward.

1. Enable or disable data roaming on SIM 1 will also do the same on SIM 2, vice versa.
2. Enable or disable automatic selection on SIM 1 will also do the same on SIM 2, vice versa.
3. When switch SIM 1 either data/message/A-GPS APN setting, i.e. select 2nd item in data apn setting, SIM 2 data setting will be set to "custom", vice versa.
Flags: needinfo?(echu) → needinfo?(arthur.chen)
The root cause of these three issues are different. It would be easier to track them with separate bugs, thanks!
Flags: needinfo?(arthur.chen)
(Reporter)

Comment 9

5 years ago
Nominate due to settings should be separated, but now some configurations will affect 2 SIM globally.
blocking-b2g: --- → 1.3?
(Reporter)

Comment 10

5 years ago
Split bugs and this one will be used to track:

1. Enable or disable data roaming on SIM 1 will also do the same on SIM 2, vice versa.
Summary: [DSDS] Cellular & Data settings for SIM 1 and SIM 2 are not independent. In many ways they affect each other. → [DSDS] Enable or disable data roaming on SIM 1 will also do the same on SIM 2, vice versa.

Updated

5 years ago
Depends on: 961921
Whiteboard: dsdsrun1.3-2 → dsdsrun1.3-2 [FT:RIL]
Ken

Please take a look for blocker
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(kchang)

Comment 12

5 years ago
In order to fix this bug, we needs to do the setting changes for RIL and affect the partner's RIL, I wonder if it is good time to do it in this stage. Can we let SIM1 and SIM2 to share one setting for these items for 1.3?(roaming, automatically selection, and so on).
Hsinyi, can you please help to discuss this with QA, UX, and Gaia?
Flags: needinfo?(kchang) → needinfo?(htsai)
(In reply to Ken Chang[:ken] from comment #12)
> In order to fix this bug, we needs to do the setting changes for RIL and
> affect the partner's RIL, I wonder if it is good time to do it in this
> stage. Can we let SIM1 and SIM2 to share one setting for these items for
> 1.3?(roaming, automatically selection, and so on).
> Hsinyi, can you please help to discuss this with QA, UX, and Gaia?

Just discussed with QA:
1.3 user story doesn't explicitly describe if we should have a global setting for roaming or not. It makes sense to have separate settings for roaming, and that's why QA nominated this as 1.3+.

It's fine to fix it later if there's a concern on partner's side. 
de-nominate and let PM make the last call.
blocking-b2g: 1.3+ → 1.3?
Flags: needinfo?(htsai)

Updated

5 years ago
Blocks: 959978

Comment 14

5 years ago
release triage Product team assessment: We can live without this for 1.3 release. Let's target it for 1.4.

Updated

5 years ago
blocking-b2g: 1.3? → 1.4?

Comment 15

5 years ago
Wesley,

Could you help to triage this one? If it is needed in v1.4, we need to know the spec. for the evaluation of feasibility on supporting.
Flags: needinfo?(whuang)

Comment 16

5 years ago
We don't have plan to do it in 1.4.
blocking-b2g: 1.4? → ---
Flags: needinfo?(whuang)
No longer blocks: 942446
It is a little bit confusing that 2 switches controls the same thing.

Same bug on Data roaming toggle.
https://bugzilla.mozilla.org/show_bug.cgi?id=975755
blocking-b2g: --- → 2.0?

Comment 18

5 years ago
Backlog this bug.
blocking-b2g: 2.0? → backlog
Whiteboard: dsdsrun1.3-2 [FT:RIL] → dsdsrun1.3-2
Just to let you know, gecko part for separating data roaming for each SIM has already been landed, see bug 961921. Do we have plans to fix it in gaia?
Assignee: nobody → arthur.chen
tracking-b2g: --- → +
(Assignee)

Updated

4 years ago
blocking-b2g: backlog → ---
Assignee: crh0716 → nobody

Comment 20

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.