Closed Bug 960615 Opened 6 years ago Closed 2 years ago

[email] Re-enable "Undo" UI for deletion/moves and remove modal confirmation prompt once backend support is present

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dietrich, Unassigned)

References

Details

(Keywords: feature)

Undo is fewer steps to do what user wants and less destructive.

See also bug 804916.
Needs ux input and roadmap scheduling.
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: feature
Flagging Matej as this would conceivably influence copy choices across the OS, and perhaps be deserving of a broader copy audit for contexts in which Undo is more appropriate.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(Mnovak)
The UX pattern for the status bar across the bottom that displays with Undo is still present in the app, but there's an l10n issue with longer translated strings for 'undo'.  Which is to say, we sorta already know what to do for UX, although that was 4 UX designers ago and there have been some other overhauls.  These can be found in the original e-mail app wireframes.
Depends on: 804904
Summary: change from delete to undo → [email] Re-enable "Undo" UI for deletion/moves and remove modal confirmation prompt once backend support is present
I'm happy to help advise, but this seems like more of a UX call. "Undo" is fine by me, but it seems like should be more of a case-by-case thing.
Flags: needinfo?(Mnovak)
Duplicate of this bug: 1178338
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.