Closed Bug 960623 Opened 7 years ago Closed 7 years ago

Enable wifi power save mode

Categories

(Firefox OS Graveyard :: Wifi, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 979130
1.4 S6 (25apr)

People

(Reporter: vasanth, Unassigned)

Details

(Keywords: perf, power, Whiteboard: [c=power p= s=2014.04.25 u=])

When wifi is going to be used in sleep mode (bug 930969 and bug 930972) we need a way to enable wifi power save mode

From bug 950124 comment 16,
Gecko already has DOM Wifi SetPowerSavingMode api. However currently Gaia/Gecko never calls it.

In Android, power save mode is enabled in WifiStateMachine.java, when 3 conditions are satisfied [1], else disabled
1. Screen state is off [2]
2. DHCP set up is not going on [3][4] and
3. High performance user option is disabled. [5]

Gaia/DOM wifi may call this api similar to what Android does to enable power save mode

[1] https://www.codeaurora.org/cgit/quic/la/platform/frameworks/base/tree/wifi/java/android/net/wifi/WifiStateMachine.java?h=jb_3.2#n391
[2] https://www.codeaurora.org/cgit/quic/la/platform/frameworks/base/tree/wifi/java/android/net/wifi/WifiStateMachine.java?h=jb_3.2#n1268
[3] https://www.codeaurora.org/cgit/quic/la/platform/frameworks/base/tree/wifi/java/android/net/wifi/WifiStateMachine.java?h=jb_3.2#n1877
[4] https://www.codeaurora.org/cgit/quic/la/platform/frameworks/base/tree/wifi/java/android/net/wifi/WifiStateMachine.java?h=jb_3.2#n1911
[5] https://www.codeaurora.org/cgit/quic/la/platform/frameworks/base/tree/wifi/java/android/net/wifi/WifiStateMachine.java?h=jb_3.2#n1138
Chuck, you should think about it when you design wifi lock mechanism. should we call this function in gecko? Or it is supposed to be called by system app.
Flags: needinfo?(chulee)
The conditions above should be treated as one of the rules for determining wifi power mode.
Just like the wifi lock, Since screen is controlled by system app, this adjustment can only be performed by it.
So wifi lock is only one of the conditions, like 3 conditions above, for determining wifi power mode for system app.

Side not: we don't provide notification for DHCP state yet.
Flags: needinfo?(chulee)
Keywords: perf, power
Whiteboard: [c=power p= s= u=]
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 979130
Priority: -- → P2
Whiteboard: [c=power p= s= u=] → [c=power p= s=2014.04.25 u=]
Target Milestone: --- → 1.4 S6 (25apr)
You need to log in before you can comment on or make changes to this bug.