Closed Bug 960701 Opened 6 years ago Closed 9 months ago

HTML5 audio device change

Categories

(Core :: Audio/Video: cubeb, defect, P4)

29 Branch
x86_64
Windows 7
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: zvonimir.gracin, Unassigned, NeedInfo)

References

Details

Steps to reproduce:
1. Play Youtube content in HTML5 mode
2. Change default audio device 

Actual results:
Audio continues to play on previous default device

Expected results:
Audio should be transferred to new default audio device
Whiteboard: [triage] [defect] p=0
Component: General → Video/Audio
Product: Firefox → Core
Same thing on on latest Aurora.
Anyone to confirm this?
Version: 27 Branch → 29 Branch
Blocks: fxdesktoptriage
No longer blocks: fxdesktopbacklog
Whiteboard: [triage] [defect] p=0 → [triage] p=0
Blocks: fxdesktopbacklog
No longer blocks: fxdesktoptriage
Whiteboard: [triage] p=0 → p=0
No longer blocks: fxdesktopbacklog
Whiteboard: p=0
also see bug 698079
Component: Audio/Video → Audio/Video: MSG/cubeb/GMP
Likely unchanged - we don't switch audio devices on the fly unless the OS hides it from us.
Status: UNCONFIRMED → NEW
Component: Audio/Video: MediaStreamGraph → Audio/Video: cubeb
Ever confirmed: true
Priority: -- → P3
Mass change P3->P4 to align with new Mozilla triage process.
Priority: P3 → P4
Duplicate of this bug: 1420290
I cannot reproduce this on my mbp and Windows PC. A similar issue, bug 1361336, has been fixed a few months ago. 
Zvonimir1974, do you still have same problem?
Flags: needinfo?(zvonimir.gracin)
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.