B2G RIL: Extend vendor RIL(baseband modem) in order to have an APDU-based logical channel communication with UICC

RESOLVED DUPLICATE of bug 921320

Status

Firefox OS
RIL
RESOLVED DUPLICATE of bug 921320
4 years ago
4 years ago

People

(Reporter: Ming Yin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310
(Reporter)

Updated

4 years ago
Depends on: 949293
(Reporter)

Comment 1

4 years ago
The SIM/UICC card is connected to the modem or baseband processor, but not to the application processor. The Firefox OS runs on the application processor, thus has limited or no access to the SIM card. In case of e-wallet based NFC payment, there is a requirement for enabling SIM access from the web application layer. 

In order to support the new function, the existing RIL implementation needs to be extended in order to have an APDU-based logical channel communication with SIM card. Communication with the SIM card is provided by the baseband processor over AT commands (e.g. AT+CPIN, AT+CRSM) defined by 3GPP 27.007 specification or through an proprietary IPC interface.

Please find the related documents for the requested RIL extensions.

http://seek-for-android.googlecode.com/files/RIL_Extensions.tgz
Seems duplicated by Bug 921320
(Reporter)

Comment 3

4 years ago
yes, you are right. I will removed this bug and add the document to your Bug 921320.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 921320
You need to log in before you can comment on or make changes to this bug.