Closed Bug 921320 Opened 7 years ago Closed 5 years ago

B2G RIL: update the impl for iccOpenChannel, iccExchangeAPDU and iccCloseChannel

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-)

RESOLVED DUPLICATE of bug 1120177
blocking-b2g -

People

(Reporter: allstars.chh, Unassigned)

References

Details

Current the implementation for iccOpenChannel, iccExchangeAPDU and iccCloseChannel use some private RIL requests and only work for some modem.

We should re-implement it by using SIM_IO so these APIs can be more portable.
Hi Anshul,
I try to use SIM_IO to implement MANAGE_CHANNEL per TS 102.221, 11.1.17.
But I always get REQUEST_NOT_SUPPORTED(error 6)

Do you know if MANAGE_CHANNEL is supported on your modem?

Thank you, : )
Assignee: nobody → allstars.chh
Hi, Anshul
Sorry for ping you again.

As you can see Bug 840780 there's already some inquiries about Secure Element on UICC.
Also there are some upcoming feature, like NFC Secure Element(Bug 879861), and EAP-SIM will need to access to the UICC.

Can you kindly help to provide some information that is there any RIL request doing this?
Like MANAGER_CHANNEL from TS 102.221, 11.1.17, or AT+CCHO, AT+CCHC, AT+CRLC from TS 27.007, 8.44~8.46.

Thank you. :)
Flags: needinfo?(anshulj)
Blocks: 923359
Hey Yoshi, sorry for the delay as I was on PTO. Let me check with the team and get back to you.
Flags: needinfo?(anshulj)
(In reply to Yoshi Huang[:allstars.chh][:yoshi] from comment #2)
> Hi, Anshul
> Can you kindly help to provide some information that is there any RIL
> request doing this?
> Like MANAGER_CHANNEL from TS 102.221, 11.1.17,
and MANAGE_SECURE_CHANNEL from TS 102.221, 11.1.20

> or AT+CCHO, AT+CCHC, AT+CRLC
                         ^^^^^^ should be AT+CRLA
> from TS 27.007, 8.44~8.46.
> 
and AT+CGLA from 8.43
(In reply to Yoshi Huang[:allstars.chh][:yoshi] from comment #4)
> (In reply to Yoshi Huang[:allstars.chh][:yoshi] from comment #2)
> > Hi, Anshul
> > Can you kindly help to provide some information that is there any RIL
> > request doing this?
> > Like MANAGER_CHANNEL from TS 102.221, 11.1.17,
> and MANAGE_SECURE_CHANNEL from TS 102.221, 11.1.20
> 
> > or AT+CCHO, AT+CCHC, AT+CRLC
>                          ^^^^^^ should be AT+CRLA
> > from TS 27.007, 8.44~8.46.
> > 
> and AT+CGLA from 8.43
Yoshi, confirmed from the UIM team that there is no RIL request for MANAGE_SECURE_CHANNEL, still waiting for an updated from the UIM team regarding the request not supported error using IccIO method you are using.
(In reply to Anshul from comment #5)
> Yoshi, confirmed from the UIM team that there is no RIL request for
> MANAGE_SECURE_CHANNEL, still waiting for an updated from the UIM team
> regarding the request not supported error using IccIO method you are using.

Thank you, Anshul. :)
blocking-b2g: --- → 1.3+
Target Milestone: --- → 1.3 Sprint 5 - 11/22
Whiteboard: [FT:RIL]
Yoshi, it seems like we are discussing already via email regarding how to go about adding support for EAP and I see you are on that thread. Greg Grisco is actively working on finding the possible solutions and would update on the email thread when he has more information.
(In reply to Anshul from comment #7)
Anshul, can you please keep checking with your UIM team? This is not only for EAP but also for NFC. Thanks.
Flags: needinfo?(anshulj)
Ken and Yoshi, QC won't be supporting NFC for 1.3 given the resource constraint so unfortunately we won't be able to help much right now.
Flags: needinfo?(anshulj)
(In reply to Anshul from comment #9)
> Ken and Yoshi, QC won't be supporting NFC for 1.3 given the resource
> constraint so unfortunately we won't be able to help much right now.
Will you support it in 1.4? Since Partner/Moz plan to have NFC payment in 1.4.
Flags: needinfo?(anshulj)
Ken, I haven't scoped 1.4 just yet so I won't be able to commit anything right now.
Flags: needinfo?(anshulj)
Blocks: 938986
No longer blocks: 938986
Target Milestone: 1.3 Sprint 5 - 11/22 → 1.3 Sprint 6 - 12/6
request to downgrade this bug for EAP_SIM feature will be handled in wpa supplicant.
Also Secure Element isn't planed for 1.3
blocking-b2g: 1.3+ → 1.3?
Remove Target MileStone per Comment 12.
Target Milestone: 1.3 Sprint 6 - 12/6 → ---
blocking-b2g: 1.3? → -
On the real device, the RIL is provided by RIL vendor as closed source. In this case, we need the vendor support for the mentioned extensions. The company G&D(Giesecke & Devrient) had specified the documents how these expected extensions look like. The doc link is 


Please find the related documents for the requested RIL extensions, which were specified by the company G&D(Giesecke & Devrient). These documents are available on public website.

http://seek-for-android.googlecode.com/files/RIL_Extensions.tgz
(In reply to Yoshi Huang[:allstars.chh] from comment #16)
> As found by Sidd, RIL v10 will have requests for openChannel.
> 
> https://android.googlesource.com/platform/hardware/ril/+/
> d78be248d253e6a5c46749b78d16115d547ab272^1..
> d78be248d253e6a5c46749b78d16115d547ab272/

That means that if we want to use these interfaces for some feature, those features can only works after RIL 10.
And this is not happened in v1.5 and v1.6.
Whiteboard: [FT:RIL]
Depends on: 1016003
Whiteboard: [ETA: 12/15]
For MozRIL these doesn't work so remove dependency on SE and clear ETA
Assignee: allstars.chh → nobody
No longer blocks: 879861
Whiteboard: [ETA: 12/15]
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120177
You need to log in before you can comment on or make changes to this bug.