Closed Bug 960800 Opened 7 years ago Closed 7 years ago

[B2G][SMS][RTSP] RTSP link doesn't appear as hyperlink when SMS is received

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0M+, b2g-v1.3T affected, b2g-v2.0 affected, b2g-v2.0M verified, b2g-v2.1 fixed, b2g-v2.2 verified)

RESOLVED FIXED
2.1 S4 (12sep)
blocking-b2g 2.0M+
Tracking Status
b2g-v1.3T --- affected
b2g-v2.0 --- affected
b2g-v2.0M --- verified
b2g-v2.1 --- fixed
b2g-v2.2 --- verified

People

(Reporter: sarsenyev, Assigned: lchang, Mentored)

References

Details

(Whiteboard: permafail,)

Attachments

(9 files)

Description:
When SMS is received, the rtsp link is shown as a regular text without a link provided.

Repro Steps:
1) Updated Buri to BuildID: 20140115004003
2) Send any working RTSP link as SMS to the testing device

Actual:
SMS is received as text file and cannot be opened as RTSP stream

Expected:
SMS is received as the hyperlink and could be opened as RTSP stream

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140115004003
Gaia: 14e199d6a9ad917eacad883820a9f7619dbf42c8
Gecko: d7260b206e91
Version: 28.0a2
Firmware Version: 1.2-device.cfg

Notes:
Repro frequency: 100%
https://moztrap.mozilla.org/manage/cases/?filter-id=2542
See attached: attached image
Component: Gaia::Browser → Gaia::SMS
Whiteboard: burirun1.3-2 → burirun1.3-2, buri1.4-1
This fixing(or should be a new feature) could be in sms link_helper.js[1] and having a rtsp check with opening a video activity in activity_picker.js should be enough.

https://github.com/mozilla-b2g/gaia/blob/master/apps/sms/js/link_helper.js#L111
Assignee: nobody → schung
Steve, should we make this a mentored bug?

Also, do you know if RTSP links are supported in the platform?
(In reply to Julien Wajsberg [:julienw] from comment #2)
> Steve, should we make this a mentored bug?
> 
> Also, do you know if RTSP links are supported in the platform?

oh, that's sounds a good idea since we are not hurry for this feature.
Bug 963565 comment 3 describe current RTSP support in FXOS. Seems video app should be able to support RTSP link as source url.
Assignee: schung → nobody
Whiteboard: burirun1.3-2, buri1.4-1 → burirun1.3-2, buri1.4-1, [mentor=:steveck]
Whiteboard: burirun1.3-2, buri1.4-1, [mentor=:steveck] → permafail, [mentor=:steveck]
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Mentor: schung
Whiteboard: permafail, [mentor=:steveck] → permafail,
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
I'd like to take a look at this bug.
Assignee: nobody → lchang
Status: NEW → ASSIGNED
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(dharris)
Attached file Pull Request 23624
Hi Steve, I've done my patch. Could you take a look? Thanks.
Attachment #8483186 - Flags: review?(schung)
Just a quick note: to view RTSP links use an url view activity, it will start playing the video properly in a browser window. I've added support for it in bug 1046602. The video app is not used anymore for playing RTSP links.
(In reply to Gabriele Svelto [:gsvelto] from comment #6)
> Just a quick note: to view RTSP links use an url view activity, it will
> start playing the video properly in a browser window. I've added support for
> it in bug 1046602. The video app is not used anymore for playing RTSP links.

Yeah, we just confirmed with video app peer about supporting the RTSP. Video element does support RTSP links for streaming, but they should not use for playing the RTSP link.
Comment on attachment 8483186 [details] [review]
Pull Request 23624

Hi Luke, I just have a nit about hthe comment, thanks!
Attachment #8483186 - Flags: review?(schung) → review+
Hi Steve, 

Thanks for reviewing. I've addressed the comment and landed it on master branch.

https://github.com/mozilla-b2g/gaia/commit/3a15400a2283a63b22f20206e014153e1c11dbbe
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(ktucker)
Whiteboard: permafail, → permafail, [2.1-flame-test-run-2]
Whiteboard: permafail, [2.1-flame-test-run-2] → permafail,
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(ktucker)
Hi Luke,
This is generic bug also happen in 2.0M. 
Could you please request approval in 2.0M? Thank you!
blocking-b2g: --- → 2.0M+
Flags: needinfo?(lchang)
Attached file Pull Request for 2.0m
Hi Josh,

Sure. I've uploaded the pull request for 2.0m. Let's wait for TBPL.
Flags: needinfo?(lchang)
Comment on attachment 8500372 [details] [review]
Pull Request for 2.0m

Hi Ben,

This is a patch for the partner branch and they would like to support "rtsp" link from Messages app. I uplifted the patch from master branch but found that the activity of browser app doesn't support "rtsp" in v2.0. Therefore, I modified the manifest of browser app accordingly. Would you mind giving me some feedback? Thanks.
Attachment #8500372 - Flags: feedback?(bfrancis)
Attachment #8500372 - Flags: feedback?(bfrancis) → feedback+
This issue is still reproducaeable in the latest 2.1 KK Flame build:

Enviromental Variables:
----------------------------------------
Device: Flame 2.1
BuildID: 20141010000201
Gaia: bc8eb493311c58f1f311a56b8b645b52bfbd2f71
Gecko: 72c13d8631ff
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

When the user receives an RTSP link via SMS, the link is not highlighted and the user cannot select the link
Yeah, this didn't land in 2.1.

Steve, should we ask for approval?
Flags: needinfo?(schung)
(In reply to Julien Wajsberg [:julienw] from comment #15)
> Yeah, this didn't land in 2.1.
> 
> Steve, should we ask for approval?

ya, let the release management decides whether we need this in 2.1.
Flags: needinfo?(schung)
Comment on attachment 8483186 [details] [review]
Pull Request 23624

Since browser already migrate to system browser in 2.1 , we could simply uplift master's patch now. 

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: User could not open rtsp link from message app
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Attachment #8483186 - Flags: approval-gaia-v2.1?
Attachment #8483186 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Hi Josh,
   According to the issue steps,the verify result as follows:
On Flame 2.1 build, it displays a blank web when open the link;
On Woodduck 2.0 build,it prompt the file is corrupt when open the link;
On Flame 2.2 build, the link is played successfully.
Test file:
rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov

Flame 2.1:
Foudn time:10:16
occurrence:10/10
Attachment:Flame21.mp4,logcat_1016.txt
Build version:
Gaia-Rev        4c159e75a1568afbbf0c83c1235ec56facfbe87d
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b9849b3c6aaa
Build-ID        20141112001201
Version         34.0

Woodduck2.0:
Foud time:10:29
Occurrence:10/10
Attachments:Woodduck20.mp4,logcat_1029.txt
Build version:
Gaia-Rev        7bc7f75d712ccef535fd371bfcc7fe61dcdcf874
Gecko-Rev       8f21e6d8abf8ee01d8da066495d8febf3138375a
Build-ID        20141113050313
Version         32.0

Flame 2.2:
Build version:
Gaia-Rev        5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/688f821edcd4
Build-ID        20141112040208
Version         36.0a1
Group: woodduck-confidential
Flags: needinfo?(jocheng)
Attached video Woodduck20.mp4
Attached file logcat_1029.txt
Attached video Flame21.mp4
Attached file logcat_1016.txt
Hi Hubert,
Can you verify the behavior on 2.0M and 2.1 again base on the verification result of Coler? Thanks!
Blocks: Woodduck
Flags: needinfo?(jocheng) → needinfo?(hlu)
(In reply to Josh Cheng [:josh] from comment #24)
> Hi Hubert,
> Can you verify the behavior on 2.0M and 2.1 again base on the verification
> result of Coler? Thanks!

Hi Josh,
    For Flame 2.1 and 2.2, my result is the same to comment 19. 
    For woodduck 2.0m, I reproduce it on new device with TCL build. RTSP link appears as hyperlink, and it could play properly.
Flags: needinfo?(hlu)
Attached video Flame2.1 video
This issue has been successfully verified on woodduck 2.0 and Flame 2.2. 
See attachment: Woodduck2.0 Flame2.2.MP4
Reproducing rate: 0/5
But it has been failed on Flame 2.1, it displays a blank web when open the link;
See attachment: Flame2.1.MP4 & Flame2.1_logcat_1439.txt
Reproducing rate: 5/5
Woodduck2.0 build:
Gaia-Rev        3a98f1287fa7b604891220ba5d86982ae8f9971e
Gecko-Rev       03d3ab62d5b07b915434f2d1d68495ad5915ecd2
Build-ID        20141120103003
Version         32.0

Flame 2.1 versions:
Gaia-Rev        1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/95fbd7635152
Build-ID        20141119001205
Version         34.0

FLame2.2 build:
Gaia-Rev        e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/aa72ddfe9f93
Build-ID        20141119160202
Version         36.0a1
It should be another bug. I can't open a RTSP link even in the browser.
Please refer to Bug 1096200 for the further discussion.
Hey Josh, can we make this bug non-confidential? It was made confidential after a patch landed...
Flags: needinfo?(jocheng)
(In reply to Julien Wajsberg [:julienw] from comment #31)
> Hey Josh, can we make this bug non-confidential? It was made confidential
> after a patch landed...

Hi Julien,
Sure, I see no confidential data included. Thanks!
Group: woodduck-confidential
Flags: needinfo?(jocheng) → needinfo?(felash)
Flags: needinfo?(felash)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/11039/
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage+][lead-review+][MGSEI-Triage+]
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.