Bug 960915 (emergencycall-as-app)

[LockScreen][EmergencyCall] Make EmergencyCall as an app

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: snowmantw, Assigned: snowmantw)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

46 bytes, text/x-github-pull-request
timdream
: review+
Details | Review | Splinter Review
46 bytes, text/x-github-pull-request
Details | Review | Splinter Review
Since we're implement SecureWindow to instead the embedded iframe, the emergency panel should be an standalone app, and follow the app creation/displaying/destroying logic to be managed.
(Assignee)

Updated

4 years ago
Alias: emergencycall-as-app
Assignee: nobody → gweng
Blocks: 960381
(Assignee)

Comment 1

4 years ago
Created attachment 8377009 [details] [review]
Patch

* Move the original system/emergency-call from System to an individual app.
* Use SecureWindow mechanism to launch it in LockScreen.
Attachment #8377009 - Flags: review?(timdream)
(Assignee)

Comment 2

4 years ago
Created attachment 8380437 [details] [review]
Patch

New patch to bubble-tea because of the 1.4 landing policy.
Attachment #8377009 - Attachment is obsolete: true
Attachment #8377009 - Flags: review?(timdream)
Attachment #8380437 - Flags: review?(timdream)
(Assignee)

Updated

4 years ago
Whiteboard: [in-bubble-tea]
(Assignee)

Comment 3

4 years ago
Travis is green: https://travis-ci.org/mozilla-b2g/gaia/builds/19561555

I'll fix some minor issues and waiting review again.
(Assignee)

Comment 4

4 years ago
Tim, since this bug is on the original v1.4 plan and should be done before 2/28, can you give me some feedback? Thanks.
Flags: needinfo?(timdream)
(In reply to Greg Weng [:snowmantw][:gweng][:λ] from comment #4)
> Tim, since this bug is on the original v1.4 plan and should be done before
> 2/28, can you give me some feedback? Thanks.

I would worry this is to much of a change for bubble-tea, but I might be wrong. Let's discuss this offline.
Flags: needinfo?(timdream)
(Assignee)

Updated

4 years ago
Whiteboard: [in-bubble-tea]
Attachment #8380437 - Flags: review?(timdream) → review+
(Assignee)

Comment 6

4 years ago
I'll land it after rebase and wait for the tests.
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

4 years ago
Gareth's six questions:

- Is this a good idea?
> Yes. Since we have SecureWindow in LockScreen, we can finally remove all embedded iframes and to make them launched as an real app. While the camera is already an app, we need to make the emergency call as an app, too.

- What problem does it solve (and for whom)?
> As above.

- Is it high priority?
> Yes. Because this blocks the LockScreen refactoring plan I mentioned in dev-gaia.

- Are there any risks involved in doing this?
> I've tested with Travis (still on going) and manually tried it on my ZTE Open. But maybe there would be some regressions.

- Who should I ask for input?
> Still don't know what the 'input' is...

- Who should at least know that this is happening?
> Tim Guan-tin Chien
(Assignee)

Comment 8

4 years ago
Oh, sorry for the inverted format. I'll correct it at the next bug.
(Assignee)

Comment 10

4 years ago
Created attachment 8398299 [details] [review]
New Patch

Since it's only different at the branch I want to merge, I keep the original one to show the r+ flag.
(Assignee)

Comment 11

4 years ago
And I must mention about the opening and closing animation: Rob had discussed this with me, that he felt the old animation (from the right to left) would be confused with the Haida's sheet animation. So we should change secure apps' animation as it perform now (fade in/out).
(Assignee)

Comment 13

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/8d9ba52b0340504acc024d0bfdd8717d674ab490

Hope it would be backed out.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

4 years ago
LOL would *NOT* be backed out.

Comment 15

4 years ago
lol, it's passed on the device CI Greg!
Thanks heaps for updating the tests :)
(Assignee)

Comment 16

4 years ago
Great! And thanks for the information!

Updated

4 years ago
Depends on: 1030546
You need to log in before you can comment on or make changes to this bug.