Closed Bug 96096 Opened 19 years ago Closed 17 years ago

Default font scaling (zoom) preference.

Categories

(Core :: Layout: Text and Fonts, enhancement, P5)

All
Linux
enhancement

Tracking

()

VERIFIED WONTFIX
Future

People

(Reporter: dylang, Unassigned)

References

Details

(Keywords: access)

Attachments

(1 file, 1 obsolete file)

It'l really nice to see that I can enlarge a font quickly within Mozilla, but
would it be possible to add a pref to the usability that lets me specify the
default scaling?  I hate having to manualy enlarge almost every page I try to read.
Would being able to set a minimum font size do (bug 30910)?
No.  A min font size is different from a default scale (like 110%, or 150%, or 85%).

Min fonts mean you don't get stupid teeny fonts forced.  Scaling means
everything is bigger by for a percent :)
UI Design
Assignee: asa → mpt
Component: Browser-General → User Interface Design
QA Contact: doronr → zach
Marking nEW.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Worksforme. You can set both default font sizes, and default font scaling, in
the `Fonts' prefs panel.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
I fail to see a default font scaling pref.  There is a MINIMUM SIZE pref, but
there is no default scale pref in 2001101221.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
the view->text zoom menu option should do all that you need.
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → WORKSFORME
Maybe I'm not coming across here.  Something is just not connecting.

I want a FONT DIALOG PREFERENCE that says, "make the default scale percentage
this..."

I KNOW how to change the scaling manually with my mouse wheel or a dialog. 
Those do it ONCE, ON A WINDOW-BY-WINDOW BASIS.

I want a DEFAULT PREFERENCE FOR ALL WINDOWS.

THESE ARE NOT THE SAME THINGS.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
The user initiated zoom/scaling setting works only for the
current window. It gets reset to 100% for any additional
Tab'ed windows or when you re-start the browser. So if someone
wants to permanently reset the value, either you need a UI
or some pref item to put into the prefs.js. Does anyone know
if the latter is possible?
no need to shout. calm down and drink some cool-aid.
Arg!

After writing a perfectly logical bug name ("*Default* font scaling pref"),
noteing that it was different from font size, having it marked "worksforme"
(even though it's a request for a feature that doesn't exist....) and having to
re-open it, you went and marked it closed again!

It's very frustrating for you to not understand my desire to have a default
scale percentage like the one found in Opera.  All that needs to happen is have
a XUL thing in the Fonts dialog which is a spinny dealy with a range of 1-999
(default to 100% if no line found), and change the code in the Window.new to set
default font size for the window from this pref.

If I knew XUL, or was pointed at a "howto" + knew where the window.new code that
was relevant was, I'd generate the patch myself.  It's that much more
frustrating how close I am to seeing this feature.
ok, the next step to getting this bug fixed is a spec, that is mpt's job unless 
someone else feels like doing it first which doesn't happen much, also, 
please open a thread on netscape.public.mozilla.ui (news.mozilla.org) 
which includes this bug number to discuss the issue. Again, there is no 
need to scream, shout, or complain.
First, I am perfectly calm.

It seems to me that this bug has been closed even though the issue has not
been addressed.

I would suggest that it is reasonable for a person to be frustrated when
their comments are so clearly being ignored. In fact the expression of 
frustration I see is fairly polite.  I have not found that 'flippant' 
responses to frustration tend to be well recieved.

On to the issue:

 Some people would like all web pages scaled up(down) a bit. While it is
 possible to do this on a page-by-page basis there is no way to do this
 on a permanent basis. 

For people with blurry monitors or special vision requirements it would be
good if the user could permanently set enlarge the fonts. That would allow 
them to browse without having to adjust every page. While this issue would
not stop a user from browsing it could make the experience unnecessarily
irritating.

This probably should also be considered as a accessibility issue under the 
"Americans with Disablities Act".

Keywords: access
Attachment #72751 - Attachment mime type: application/octet-stream → image/png
I see that attachment 72751 [details] has a bold red line around "Display resolution" 
and the text "Default font scaling preference" in red.

Changing this does (or at least should) inversely change the effective font 
size; eg: by lowering the number one can enlarge the fonts.

I see that the drop down list has the values "71 dpi", "96 dpi" "System 
settings", 
and "Other...". Choosing "Other..." brings up a dialog asking the user to 
measure the size of a line.

As a UI design it seems to me to be non obivious and a bit hard to use. 

I think I would be hard pressed to use this to set the font size to 200%.

I guess if we are just trying to solve this particular user's need then asking
this user to set screen resolution would be okay. If we are trying to provide
the feature to the general user then perhaps we need a more obivious UI.
Why don't we just make the font zoom set through the view menu persist between
sessions and be the value used when creating a new window?
I have actually thought about this quite a bit. The reasoning is pretty subtle, 
and I won't be surprised if people call me silly, but here goes anyway.

If you want to change the size of text, that's what the Size menus are for in 
the Fonts preferences panel. If a Web author changes the size of some text, it 
should be (1) for temporary purposes (e.g. headings or disclaimers), (2) 
relative to that preferred size (using ems or %), and (3) not unreasonably 
different from the preferred size (e.g. not less than about 70% or more than 
about 500%). If a Web author breaks (1), (2), or (3), that's an evangelism 
issue: not as in `hey, support our browser' evangelism, but as in `hey, stop 
being so fricking annoying' evangelism.

So, firstly, if Text Zoom was persistent *and* the Fonts size prefs were 
persistent, the overlap between the two would become extremely confusing. And 
that would be bad.

Secondly, WYSIWYG-mentality Web authors are fond of specifying font sizes which 
are smaller than the default -- especially in Web portals where they're trying 
to cram in as many links as possible. Text Zoom is a temporary mechanism for 
coping with such badly designed sites. It makes you expend a little effort, as 
a slight discouragement from visiting sites which mess with your preferred font 
sizes. (As a random example, one of the reasons I visit Slashdot more often 
than Kuro5hin is because Kuro5hin prints *all* its text smaller than my 
preferred size.) This way, it provides a small market force encouraging site 
authors to Do The Right Thing with font sizes.

Without that force, I believe that five years from now Mozilla's default zoom 
setting would be forced up to 200 percent, and Web authors would be specifying 
40% font sizes to compensate. It would be an endless escalation, and those 
sites which were properly sticking in the vicinity of 100% would be penalized. 
And that would be bad.
What about users with who for partial visual disability reasons always want 
larger sizes?
Exactly the same argument applies, with the addition that they can use the
minimum font size preference (which did not exist when this bug was filed).
Summary: [RFE] Default font scaling preference. → Default font scaling preference.
uid is being phased out.
Assignee: mpt → font
Status: REOPENED → NEW
Component: User Interface Design → Layout: Fonts and Text
QA Contact: zach → ylong
See bug 65571, particularly bug 65571 comment 44, for why this is a bad idea.  I
would have no objections to persisting or having a preference for full zoom (bug
4821), but persisting or having a preference for text zoom is bad.
Priority: -- → P5
Target Milestone: --- → Future
Summary: Default font scaling preference. → Default font scaling (zoom) preference.
wontfix.
Status: NEW → RESOLVED
Closed: 19 years ago17 years ago
Resolution: --- → WONTFIX
Mark as verified per previous 2 comments above.
Status: RESOLVED → VERIFIED
*** Bug 214991 has been marked as a duplicate of this bug. ***
*** Bug 239738 has been marked as a duplicate of this bug. ***
*** Bug 241353 has been marked as a duplicate of this bug. ***
There is already infrastructure for this in current Firefox versions, for per site zoom. Global zoom is tracked in bug 332275.
Should this be duped?
You need to log in before you can comment on or make changes to this bug.