[curated groups] /user/edit/ Unvouched users should not be presented with the opportunity to join groups

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mbrandt, Assigned: dpoirier)

Tracking

2014-02.1

Details

(Whiteboard: [kb=1246800] [curated groups], URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8361768 [details]
qa - screencast of bug on stage

Unvouched users should not be presented with the option to join groups if this behavior is restricted to only vouched Mozillians.

Steps to reproduce:
1. using an unvouched account, goto https://mozillians.allizom.org/user/edit/
2. notice there is a join groups section
3. click on the "find group's page" link, https://mozillians.allizom.org/groups/

Expected:
If unvouched users are allowed to join groups leave the /groups/ link in place but enable the functionality.

If unvouched user aren't allowed to join groups remove the join groups section from /user/edit/

Actual:
(see screencast) Unvouched users are presented with the join groups section in /user/edit/ When a user tries to goto /groups/ they are redirected to their profile page with an error stating "You must be vouched to continue."
(Assignee)

Updated

5 years ago
Assignee: nobody → dpoirier
Status: NEW → ASSIGNED
(Assignee)

Comment 1

5 years ago
FYI Firefox says it can't play the attachment because the file is corrupt.
Whiteboard: [curated groups] → [kb=1246800] [curated groups]
(Reporter)

Comment 2

5 years ago
> FYI Firefox says it can't play the attachment because the file is corrupt.

:dpoirier - sorry you can't view this. The video wfm in my browser (encoded as a .mov). I'll make sure to use a more /standards compliant/ codec next time.

Comment 3

5 years ago
Commit pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/c121e21d4a24602c9d026dafa1ffac8d91334359
961073 Don't link to groups page for unvouched user when editing profile

Fix bug 961073

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Version: other → next
(Assignee)

Comment 4

5 years ago
Verified at https://mozillians.allizom.org/en-US/:

* unvouched users cannot visit the group list page
* unvouched users cannot follow a link to an existing group (e.g. https://mozillians.allizom.org/en-US/group/duck-dodgers-in-the-215-century/)
* unvouched users can see groups by searching, but cannot follow the links to the actual groups

In each case, the unvouched user ends up back at https://mozillians.allizom.org/en-US/ with a message "You must be vouched to continue."
(Assignee)

Comment 5

5 years ago
Created attachment 8371662 [details]
Screen shot of what an unvouched user sees when they try any of the disallowed pages.
(Assignee)

Updated

5 years ago
Status: RESOLVED → VERIFIED
Version: next → 2014-02.1
You need to log in before you can comment on or make changes to this bug.