[tracker] Allow users to create/manage groups ("Curated Groups")

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: hoosteeno, Unassigned)

Tracking

2014-02.1
Dependency tree / graph

Details

(refined from https://mozillians.etherpad.mozilla.org/curated-group-specs)

Feature: 
Allow vouched Mozillians to create groups whose membership/attributes they can manage. 

Overview:
A curated group is like a functional area, but any Mozillian can create and manage them. Curated groups have a variety of settings. Any mozillian can find a curated group, see its name, see meta-information about the group, and see its curator (but not necessarily see its individual members). Any mozillian can request to join a group. A curator can manage curated group settings. A curator can approve requests to join a group. A curator can remove people from a group.
When this feature launches, existing functional areas will be converted to curated groups with a "functional area" flag set.

Version 1 "MVF" (minimum viable feature) Stories:
* As a user,  I can create a "curated group" that will resemble our current  functional areas in functionality, and I am automatically assigned as  its curator
* Each curated group will have its own web page (detail page) similar to the existing functional areas 
*  As a user, when I visit someone else's curated group's web page, I'll see information about the group and about the curator at the top (similar to  functional areas):
    * Curator image
    * Curator name
    * Curator contact info
    * group more info URL (href) 
    * number of members
    * group overview
    * irc channel
* As a user, I can request to join a curated group unless the "Group is accepting new members" flag is set to false (see below) by clicking a button on the group's web page
* As a user, I can leave a curated group unless the "Members can leave the group" flag is set to false (see below) by clicking a button on the group's web page
* As a user if my request to join a group is accepted, I will get an email
* As a user when I search, the search results will include curated groups alongside other groups
* As a curated group owner, I will receive requests to join the group by email
* As a curated group owner, I can visit an interface that allows me to see requests to join the group, links to the profiles of requesters, and allows me to accept requests
* As a curated group owner, I can visit an interface that shows me all members of the group and allows me to remove members 
* As a curated group owner, I can visit an interface that allows me to manage the following settings about a curated group:
    ** more info URL (text)
    ** group overview (textarea with character limit: 500 chars)
    ** irc channel
    ** group name
    ** group members
* As an admin, I can do anything a curated group owner can do, to any curated group
* As an admin I can manage additional settings of a curated group using the /admin interface.
** "Members can leave the group?" (TRUE/FALSE, default TRUE)
** "Group is accepting new members?" (YES/NO/BY REQUEST, default BY REQUEST)
** "Functional area?" (TRUE/FALSE, default FALSE)
** Group owner (user picker)
* As a public user (someone not signed in) or unvouched user:
   ** (now and at release of this feature) I must login to see anything at any group URL
   ** I can see the groups that a user is a member of on a user's profile if they are shared with public users
* As a Mozilla Corp API user:
   **  (at release of this feature) I can see all groups that a person  is a member of at the /users endpoint, and I can see meta information about all groups at the /groups endpoint
  ** I can filter the /users endpoint for users in particular groups
Depends on: 936570
See Also: → bug 917968
Depends on: 937673
The great conversations spinning out from bug 936570 have helped us refine the spec a bit. 

The below stories replace their counterparts above:

* As an admin I can manage additional settings of a group using the /admin interface.
** "Members can leave the group?" (TRUE/FALSE, default TRUE)
** "Group is accepting new members?" (YES/NO/BY REQUEST, default YES)
** "Functional area?" (TRUE/FALSE, default FALSE)
** "Group visible to users?" (TRUE/FALSE, default TRUE) <-- some groups can be invisible in the UI
** Group owner (user picker)

* As a curated group owner, I can visit an interface that allows me to manage the following settings about a curated group:
    ** more info URL (text)
    ** group overview (textarea with character limit: 500 chars)
    ** irc channel
    ** group name
    ** group members
    ** group accepting new members? YES, NO or BY REQUEST, default YES
Depends on: 938184
Depends on: 938674
Depends on: 938680
Depends on: 938695
Depends on: 938723
Depends on: 939127
Blocks: 846630
When this lands, we'll need to update the Basket celery tasks and specifically the update_phonebook_task, as updated in bug 920270.

Current basket tasks consider all groups with stewards as functional areas. Instead the new "functional area" flag should be used.

Also this raises a related question about how to keep in sync the functional areas defined in mozillians with the ones tracked in ExactTarget. Thoughts?
Depends on: 926692
Depends on: 947271
Depends on: 948491
Depends on: 948640
Depends on: 950242
Depends on: 951515
Depends on: 951840
No longer depends on: 926692
Depends on: 961066
Depends on: 961073
Depends on: 961206
Depends on: 961219
Depends on: 961772
Depends on: 962191
Depends on: 962193
Depends on: 962223
Blocks: 962292
Depends on: 963295
Depends on: 964434
Depends on: 966269
Version: other → next
Depends on: 966410
No longer depends on: 961066
No longer depends on: 962223
Depends on: 959294
Version: next → 2014-02.1
Curated groups was launched! There are still some bugs outstanding, but I'm going to call this major feature tracker "Resolved". Thanks everyone for the hard work!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Depends on: 969621
Duplicate of this bug: 860504
Bumping to QA verified -- yay .. this was a big launch.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.