fail reloading form values

VERIFIED DUPLICATE of bug 46845

Status

()

Core
HTML: Form Submission
P1
critical
VERIFIED DUPLICATE of bug 46845
16 years ago
16 years ago

People

(Reporter: JS, Assigned: Radha on family leave (not reading bugmail))

Tracking

({dataloss})

Trunk
mozilla0.9.5
x86
All
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
when defined value of form is rewritten by new value, then RELOAD is hitted,
mozilla fails to insert original value to form input.

step by step:
1) make simple <FORM> and input for example: <INPUT TYPE="TEXT" NAME="name"
VALUE="jakub@salon.cz">
2) access page with form with mozilla
3) rewrite value jakub@salon.cz with anything other. do not click submit
4) hit RELOAD button
5) page still contains rewrited value instead of jakub@salon.cz
it is probably good behave, but when one rewrite original value with nothing
(blank) and hits reload, the value is still blank

screenshot available...

Comment 1

16 years ago
->form submission.
Assignee: asa → rods
Status: UNCONFIRMED → NEW
Component: Browser-General → Form Submission
Ever confirmed: true
QA Contact: doronr → vladimire

Comment 2

16 years ago
I don't see this on WinNT
Status: NEW → ASSIGNED
Priority: -- → P1
Summary: fail reloading form values → [LNX]fail reloading form values
Target Milestone: --- → mozilla0.9.5
I cannot reproduce with a local file, but can reproduce with HTTP on Win NT
(2001-08-26-08). Does not occur with shift+reload, though.

This causes dataloss on Bugzilla. If you reload a bug and someone else has
changed something like the summary, you'll get still the old summary. If you
add a comment, you'll change the summary to the old value too.

Probably this is basically the same as bug 81504.
Severity: major → critical
Keywords: dataloss
OS: Linux → All
Summary: [LNX]fail reloading form values → fail reloading form values
Bug 60269, bug 46845 and maybe bug 79063 are very similar too. If you dupe this
one to 46845, please note that it's futured, which seems not to reflect the
actual severity.

Comment 5

16 years ago
Radha is this in your area, I think we are doing this on purpose.
Assignee: rods → radha
Status: ASSIGNED → NEW
This is same as 81504

*** This bug has been marked as a duplicate of 81504 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
Doesnt look like a duplicate to me... That bug deals with reloading default
values into wrong fields, and this one deals with not reloading default values.... 
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

16 years ago
This is dupe of 46845 though...

*** This bug has been marked as a duplicate of 46845 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.