Closed Bug 961535 Opened 7 years ago Closed 7 years ago

Right clicking in the menu panel makes the footer icons jump

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: ge3k0s, Assigned: Gijs)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Australis:P3][good first verify])

Attachments

(1 file)

When you right click the menu panel to make the context menu appear the footer icons (customization/help and quit) slightly move up and down. I'm seeing that on Windows 7, I don't know about the other platforms.
Whiteboard: [Australis:P3]
(In reply to Guillaume C. [:ge3k0s] from comment #0)
> When you right click the menu panel to make the context menu appear the
> footer icons (customization/help and quit) slightly move up and down. I'm
> seeing that on Windows 7, I don't know about the other platforms.

Clean profile? I can't reproduce on my machine, but maybe it depends on what's in the panel?
Flags: needinfo?(ge3k0s)
(In reply to :Gijs Kruitbosch from comment #1)
> (In reply to Guillaume C. [:ge3k0s] from comment #0)
> > When you right click the menu panel to make the context menu appear the
> > footer icons (customization/help and quit) slightly move up and down. I'm
> > seeing that on Windows 7, I don't know about the other platforms.
> 
> Clean profile? I can't reproduce on my machine, but maybe it depends on
> what's in the panel?

Yeap clean profile. I've tested the issue quickly and it doesn't seem related to specific widgets in the panel but on the number of widgets in a row. I can only reproduce with the last row complete (3 widgets).
Flags: needinfo?(ge3k0s)
(In reply to Guillaume C. [:ge3k0s] from comment #2)
> (In reply to :Gijs Kruitbosch from comment #1)
> > (In reply to Guillaume C. [:ge3k0s] from comment #0)
> > > When you right click the menu panel to make the context menu appear the
> > > footer icons (customization/help and quit) slightly move up and down. I'm
> > > seeing that on Windows 7, I don't know about the other platforms.
> > 
> > Clean profile? I can't reproduce on my machine, but maybe it depends on
> > what's in the panel?
> 
> Yeap clean profile. I've tested the issue quickly and it doesn't seem
> related to specific widgets in the panel but on the number of widgets in a
> row. I can only reproduce with the last row complete (3 widgets).

Hrm. I still can't reproduce. Sorry! :-(

I presume this is latest nightly and win7 aero glass? Note that on latest nightlies, a clean profile should have 10 items, so 1 item (devtools) on the last row (I can't reproduce with either that config or when I remove the devtools). Do you see it when the panel is open as a panel as well as in customize mode? Is this a recent regression, and if so, do you know the regression window (e.g. from the nightly before today's?)

Also needinfo'ing Jared, in case he has ideas...
Flags: needinfo?(jaws)
Flags: needinfo?(ge3k0s)
(In reply to :Gijs Kruitbosch from comment #3)
> 10 items

That is, the 2 wide things (cut/copy/paste + zoom controls) + 10 'small' items.
(In reply to :Gijs Kruitbosch from comment #3)
> (In reply to Guillaume C. [:ge3k0s] from comment #2)
> > (In reply to :Gijs Kruitbosch from comment #1)
> > > (In reply to Guillaume C. [:ge3k0s] from comment #0)
> > > > When you right click the menu panel to make the context menu appear the
> > > > footer icons (customization/help and quit) slightly move up and down. I'm
> > > > seeing that on Windows 7, I don't know about the other platforms.
> > > 
> > > Clean profile? I can't reproduce on my machine, but maybe it depends on
> > > what's in the panel?
> > 
> > Yeap clean profile. I've tested the issue quickly and it doesn't seem
> > related to specific widgets in the panel but on the number of widgets in a
> > row. I can only reproduce with the last row complete (3 widgets).
> 
> Hrm. I still can't reproduce. Sorry! :-(
> 
> I presume this is latest nightly and win7 aero glass? Note that on latest
> nightlies, a clean profile should have 10 items, so 1 item (devtools) on the
> last row (I can't reproduce with either that config or when I remove the
> devtools). Do you see it when the panel is open as a panel as well as in
> customize mode? Is this a recent regression, and if so, do you know the
> regression window (e.g. from the nightly before today's?)
> 
> Also needinfo'ing Jared, in case he has ideas...

Yes Win 7 Aero glass. I can reproduce as soon as I remove the devtools. AFAIK it happens only since yesterday's build (01.19.2014). The issue isn't present in customization mode. It's not very noticeable. To see it it's better to right click a lot of time.
Flags: needinfo?(ge3k0s)
Flags: needinfo?(jaws)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Note also bug 924314. Not sure if they're related.
Can't reproduce anymore in latest Nightly (01-26-2014)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Then this was probably fixed by bug 924314. :-)
Resolution: WORKSFORME → FIXED
Assignee: nobody → gijskruitbosch+bugs
Target Milestone: --- → Firefox 29
Whiteboard: [Australis:P3] → [Australis:P3][good first verify]
You need to log in before you can comment on or make changes to this bug.