Closed Bug 961681 Opened 6 years ago Closed 6 years ago

[NFC] click home button after shrinking UI

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+)

RESOLVED DUPLICATE of bug 996522
1.4 S6 (25apr)
blocking-b2g 2.0+

People

(Reporter: wachen, Assigned: gweng)

References

Details

Using most up-to-date pvt build (2014/1/20 & earlier 2014/1/24) to test

STR:
1. Enable "NFC" in Settings App
2. Launch browser
3. Tap 2 phones with NFC enabled together
4. After seeing shrinking UI, press home key
5. stop tapping phones

Expected Result:
It will come back to home screen normally

Actual Result:
The background of home screen is gone with a black screen
It totally breaks the home screen UI and requires a restart.
blocking-b2g: --- → 1.4?
Whiteboard: [FT:RIL]
Moving to 1.5 as NFC is not a feature included in the de-scoped feature list.
blocking-b2g: 1.4? → 1.5?
Greg, Could you please take this bug? Thanks.
Flags: needinfo?(gweng)
This concerns to disable any homescreen and other actions that break the NFC sharing sessions (except the poweroff key pressing). I remembered that I discussed this with UX, and may provide a patch to review next week.
Flags: needinfo?(gweng)
Blocks: NFC-Gaia
No longer blocks: b2g-NFC-2.0
Assignee: nobody → gweng
Duplicate of this bug: 963011
Set target milestone. If you can not make it, please update it. Thanks.
Target Milestone: --- → 1.4 S6 (25apr)
I can't reproduce this bug on new master. Although that my device is not a truly NFC device, but I triggered the same event to let it into the shrinking mode.

Can Walter check this bug again?
Flags: needinfo?(wachen)
The video.

http://youtu.be/QvL0EHdE1tI

And I've tested it on the Nexus 5, the result is the same.
After discussed with Walter, the issue is:

1. Press home to make the foreground as background app
2. Trigger shrinking UI at this stage
3. The shrinking UI should not be triggered, but it was and would break the homescreen.
Flags: needinfo?(wachen)
Whiteboard: [FT:RIL]
blocking-b2g: 2.0? → 2.0+
Whiteboard: [systemfe]
Whiteboard: [systemfe]
Component: NFC → Gaia::System::Window Mgmt
This bug blocks NFC 2.0 release.
Blocks: b2g-NFC-2.0
(In reply to Greg Weng [:snowmantw][:gweng][:λ] from comment #9)
> After discussed with Walter, the issue is:
> 
> 1. Press home to make the foreground as background app
> 2. Trigger shrinking UI at this stage
> 3. The shrinking UI should not be triggered, but it was and would break the
> homescreen.

This case duplicate from bug 996522
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 996522
You need to log in before you can comment on or make changes to this bug.