Closed Bug 961868 Opened 8 years ago Closed 8 years ago

[e10s] Pinned tabs don't work

Categories

(Firefox :: Tabbed Browser, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: billm, Assigned: billm)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached patch pinned-tabsSplinter Review
We can't set the isAppTab property on the docshell in electrolysis. Eventually we may want to send a message to update this attribute in the child. However, we only ever use the isAppTab property when calling nsIWebBrowserChrome3::OnBeforeLinkTraversal, and that function is also unimplemented in electrolysis. So it doesn't seem worth it to do that now. I filed bug 961867 to deal with app tabs.
Attachment #8362717 - Flags: review?(felipc)
Attachment #8362717 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/01d5e4bec3b4
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Duplicate of this bug: 921905
You need to log in before you can comment on or make changes to this bug.