gstreamer backend attempts to play files even if user prefs are set to use an external app for that mimetype

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
P5
normal
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: alavaliant, Unassigned)

Tracking

26 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

I tried to load the direct url to a mov file (http://fredrik.hubbe.net/plugger/test.mov for example)


Actual results:

Rather than getting video playback a message was displayed in the middle screen; 'Video can't be played because the file is corrupt.'  


Expected results:

I would have expected the file to be downloaded and opened using the helper app set in my firefox prefs for that mimetype (In my firefox prefs edit -> preferences -> applications -> apple quicktime video  is set to run a program for mov playback).

Opening non embedded mov files using an external program works fine if media.gstreamer.enabled is set to False (or if an older version of firefox from prior to gstreamer support is used),  but as soon as gstreamer support is enabled it seems to override all user settings and try to handle mov playback itself.

Could we get either files that are set to open using external programs in the mimetype application prefs to not be handled by the gstreamer/html5 video code or atleast some sort of hidden pref blacklist so we can force the gstreamer/html5 player code to ignore certain mime types/file extensions?
Component: Untriaged → Plug-ins
Product: Firefox → Core
This page has "Content-type: video/quicktime". If i set "video/quicktime" to be handled by the app, it works fine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

4 years ago
I've done further testing on this matter and it looks like firefox's gstreamer support only tries to take over video/quicktime files if the gstreamer*-ffmpeg package is installed on the machine you are running firefox on.   

If gstreamer ffpmeg support isn't present mov files can't be handled internally and the set app is used to handle such files.       Unfortunately as best as I can tell mpeg4/mp4 video playback requires the gstreamer ffpmeg package as well so just removing that package isn't really a fix since not being able to play mpeg4 videos removes the main point of having gstreamer support enabled in firefox.

I'd guess you didn't have gstreamer ffmpeg support enabled on your machine Georg which would explain why you were able to play such videos without the gstreamer support trying to take over playback.
Ok, good point. Johns, do you know to what component a bug on this possibly wrong mimehandling could go?
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(jschoenick)
Resolution: WORKSFORME → ---
the gstreamer work is being tracked in video/audio, so that's my guess unless a more specific component is identified.
Blocks: 886181
Component: Plug-ins → Video/Audio
Flags: needinfo?(jschoenick)
Component: Audio/Video → Audio/Video: Playback
Priority: -- → P5
gstreamer is going in bug 1234092
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.