Closed Bug 962062 Opened 6 years ago Closed 6 years ago

All download entries of the same file are removed from history when one entry is deleted

Categories

(Toolkit :: Downloads API, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 825887

People

(Reporter: cornel_ionce, Unassigned)

Details

User Agents:
Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (X11; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:27.0) Gecko/20100101 Firefox/27.0

Build ID: 20140120132616

This issue was found during the Firefox 27 beta 8 testing.

Steps to Reproduce:
1. Open Firefox.
2. Download the same file twice (or several) times.
3. Wait for the downloads to finish.
4. Select Show all downloads
5. Right click any of the downloaded files and select "Remove from history".

Expected result:
The selected file is properly removed from the history.

Actual result:
All download entries of the same file are removed from history when one entry is deleted

Notes:
This issue is not a regression, it reproduces back to Firefox 20 when the Download Manager was released.
that's on purpose
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 825887
You need to log in before you can comment on or make changes to this bug.