Strip debug logging and PII leaks from Android Firefox Accounts before merge to Aurora

RESOLVED FIXED in Firefox 29

Status

()

defect
P1
normal
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: nalexander, Assigned: nalexander)

Tracking

(Blocks 1 bug)

unspecified
Firefox 29
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec29+)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

57 bytes, text/x-github-pull-request
rnewman
: review+
Details | Review
Mostly this means toggling FxAccountConstants.LOG_PERSONAL_INFORMATION to false, but we'll want to give all the Firefox Accounts code a once over for potentially bad logging.
Whiteboard: [qa-]
tracking-fennec: --- → 29+
Priority: -- → P1
Duplicate of this bug: 963451
Posted file github PR
Couple of Sync's look fine.   We really aren't going to help our debugging with this; we'll want to follow up with some better (but non PII) logging of the sign in flow soon.
Attachment #8368134 - Flags: review?(rnewman)
Attachment #8368134 - Flags: review?(rnewman) → review+
https://hg.mozilla.org/services/services-central/rev/1c6a696b65a7
Status: NEW → ASSIGNED
Whiteboard: [qa-] → [qa-][fixed in services]
https://hg.mozilla.org/mozilla-central/rev/1c6a696b65a7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [qa-][fixed in services] → [qa-]
Target Milestone: --- → Firefox 29
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.