Closed Bug 962273 Opened 6 years ago Closed 6 years ago

Launching apps in Gaia stopped working

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: eeejay, Assigned: eeejay)

References

Details

(Keywords: regression)

Attachments

(1 file)

This is while running Gaia via Firefox on Linux.

I see the nsIDOMApplication.launch() method being called, and after that, nothing. This is a regression from bug #959420.
blocking-b2g: --- → 1.4?
Keywords: regression
I can launch apps just fine on desktop and device using b2g-inbound+gaia-master, so I'm not convinced that this bug is actually valid.
Haven't tried b2g-inbound, just central and inbound. But reverting the patches from that bug makes everything work again.
Can you do a debug build and see if you get any useful trace?
Going to hold off nominating until we get clear STR on a production build.
blocking-b2g: 1.4? → ---
(In reply to Fabrice Desré [:fabrice] from comment #3)
> Can you do a debug build and see if you get any useful trace?

Nothing useful. I'll keep digging.
Component: DOM: Apps → Gaia
Product: Core → Firefox OS
OK, this is specific to the browser-helper extension. The shell.js there needs to be updated to use the promise API.
Attachment #8363340 - Flags: review?(fabrice) → review+
Thanks!

https://github.com/mozilla-b2g/gaia/commit/8409c1d139d4e2790d228736a6533b8e826f4cb7
Assignee: nobody → eitan
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.