"Home page lists" settings page causes Nightly to stop

RESOLVED FIXED in Firefox 29

Status

()

--
critical
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: TeoVermesan, Assigned: liuche)

Tracking

(Blocks: 1 bug, {crash, regression, reproducible})

29 Branch
Firefox 29
ARM
Android
crash, regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28 unaffected, firefox29- affected, fennec29+)

Details

(Whiteboard: [native-crash])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Tested with:
Build: Firefox for Android (2013-01-23)
Device: Alcatel One Touch
OS: Android 4.1.2

Steps to reproduce:
1. Open Firefox
2. Go to Settings -> Customize ->  Home
3. Choose any of the options

Expected results:
- The user can manage their Home page lists.

Actual results:
- Nightly freezes with the following message:"Unfortunately, Nightly has stopped"
What do you see in adb logcat? A stacktrace would be helpful here.
Flags: needinfo?(teodora.vermesan)
(Reporter)

Comment 2

5 years ago
On Samsung Galaxy Nexus (Android 4.2.1) the app crashes with this crash signature: https://crash-stats.mozilla.com/report/index/3df13b7d-cab6-42af-ae0a-11b532140123
Flags: needinfo?(teodora.vermesan)
liuche, could you have at this bug?
Assignee: nobody → liuche

Updated

5 years ago
Blocks: 941312
Depends on: 942875
Reproduced this on Nightly on N5 as well. Let me know if you need other info.

Updated

5 years ago
tracking-fennec: --- → ?
status-firefox28: --- → unaffected
status-firefox29: --- → affected
tracking-firefox29: --- → ?
E/GeckoAppShell( 3710): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1 ("main")
E/GeckoAppShell( 3710): java.lang.NullPointerException
E/GeckoAppShell( 3710): 	at android.widget.ArrayAdapter.createViewFromResource(ArrayAdapter.java:394)
E/GeckoAppShell( 3710): 	at android.widget.ArrayAdapter.getView(ArrayAdapter.java:362)
E/GeckoAppShell( 3710): 	at android.widget.AbsListView.obtainView(AbsListView.java:2240)
E/GeckoAppShell( 3710): 	at android.widget.ListView.measureHeightOfChildren(ListView.java:1263)
E/GeckoAppShell( 3710): 	at android.widget.ListView.onMeasure(ListView.java:1175)
E/GeckoAppShell( 3710): 	at android.view.View.measure(View.java:16497)
E/GeckoAppShell( 3710): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:5125)
E/GeckoAppShell( 3710): 	at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1404)
E/GeckoAppShell( 3710): 	at android.widget.LinearLayout.measureVertical(LinearLayout.java:695)
E/GeckoAppShell( 3710): 	at android.widget.LinearLayout.onMeasure(LinearLayout.java:588)
E/GeckoAppShell( 3710): 	at android.view.View.measure(View.java:16497)
E/GeckoAppShell( 3710): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:5125)
E/GeckoAppShell( 3710): 	at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1404)
E/GeckoAppShell( 3710): 	at android.widget.LinearLayout.measureVertical(LinearLayout.java:695)
E/GeckoAppShell( 3710): 	at android.widget.LinearLayout.onMeasure(LinearLayout.java:588)
E/GeckoAppShell( 3710): 	at android.view.View.measure(View.java:16497)
E/GeckoAppShell( 3710): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:5125)
E/GeckoAppShell( 3710): 	at android.widget.FrameLayout.onMeasure(FrameLayout.java:310)
E/GeckoAppShell( 3710): 	at android.view.View.measure(View.java:16497)
E/GeckoAppShell( 3710): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:5125)
E/GeckoAppShell( 3710): 	at android.widget.FrameLayout.onMeasure(FrameLayout.java:310)
E/GeckoAppShell( 3710): 	at android.view.View.measure(View.java:16497)
E/GeckoAppShell( 3710): 	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:5125)
E/GeckoAppShell( 3710): 	at android.widget.FrameLayout.onMeasure(FrameLayout.java:310)
E/GeckoAppShell( 3710): 	at com.android.internal.policy.impl.PhoneWindow$DecorView.onMeasure(PhoneWindow.java:2298)
E/GeckoAppShell( 3710): 	at android.view.View.measure(View.java:16497)
E/GeckoAppShell( 3710): 	at android.view.ViewRootImpl.performMeasure(ViewRootImpl.java:1916)
E/GeckoAppShell( 3710): 	at android.view.ViewRootImpl.measureHierarchy(ViewRootImpl.java:1088)
E/GeckoAppShell( 3710): 	at android.view.ViewRootImpl.performTraversals(ViewRootImpl.java:1295)
E/GeckoAppShell( 3710): 	at android.view.ViewRootImpl.doTraversal(ViewRootImpl.java:1000)
E/GeckoAppShell( 3710): 	at android.view.ViewRootImpl$TraversalRunnable.run(ViewRootImpl.java:5670)
E/GeckoAppShell( 3710): 	at android.view.Choreographer$CallbackRecord.run(Choreographer.java:761)
E/GeckoAppShell( 3710): 	at android.view.Choreographer.doCallbacks(Choreographer.java:574)
E/GeckoAppShell( 3710): 	at android.view.Choreographer.doFrame(Choreographer.java:544)
E/GeckoAppShell( 3710): 	at android.view.Choreographer$FrameDisplayEventReceiver.run(Choreographer.java:747)
E/GeckoAppShell( 3710): 	at android.os.Handler.handleCallback(Handler.java:733)
E/GeckoAppShell( 3710): 	at android.os.Handler.dispatchMessage(Handler.java:95)
E/GeckoAppShell( 3710): 	at android.os.Looper.loop(Looper.java:136)
E/GeckoAppShell( 3710): 	at android.app.ActivityThread.main(ActivityThread.java:5050)
E/GeckoAppShell( 3710): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/GeckoAppShell( 3710): 	at java.lang.reflect.Method.invoke(Method.java:515)
E/GeckoAppShell( 3710): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1264)
E/GeckoAppShell( 3710): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1080)
E/GeckoAppShell( 3710): 	at dalvik.system.NativeStart.main(Native Method)
E/Gecko   ( 3710): mozalloc_abort: Redirecting call to abort() to mozalloc_abort
F/libc    ( 3710): Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1), thread 3710 (.mozilla.fennec)
Severity: normal → critical
Keywords: crash, regression, reproducible
Whiteboard: [native-crash]

Updated

5 years ago
tracking-fennec: ? → 29+
(Assignee)

Comment 6

5 years ago
The results of some quick investigation - I can repro this on my Nightly, as well as the most recent m-c tbpl build. The confusing part, though, is that building a local fresh m-c pull with no additional files doesn't exhibit this crash. Investigating further...
(Assignee)

Comment 7

5 years ago
Created attachment 8364637 [details] [diff] [review]
Patch: Null check

Missed a null check.
Attachment #8364637 - Flags: review?(margaret.leibovic)

Updated

5 years ago
Attachment #8364637 - Flags: review?(margaret.leibovic) → review+
(Assignee)

Updated

5 years ago
Target Milestone: --- → Firefox 29
https://hg.mozilla.org/mozilla-central/rev/13febb220733
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 963755
I ran into this a couple days ago, this patch fixs my GS3 but my tablet N7 still fails with the same error stack.

(Fresh pull from m-c, no patches in queue, clobbered, uninstalled, rebuilt, re-installed).

Comment 12

5 years ago
:liuche, based on Comment 11 could you have a look at this?
Flags: needinfo?(liuche)
(Assignee)

Comment 13

5 years ago
This might be bug 963754 that is manifesting - I tried to run Nightly on a N7 and saw that crash instead.
Flags: needinfo?(liuche)
tracking-firefox29: ? → -
I don't think we need to track this since a patch has landed fixing it.
You need to log in before you can comment on or make changes to this bug.