Closed Bug 963109 Opened 8 years ago Closed 8 years ago

[Messages] Multi-recipient participants view should show back button instead of cross one

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(feature-b2g:2.0, tracking-b2g:backlog, b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S3 (6june)
feature-b2g 2.0
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: isabelrios, Assigned: steveck)

References

Details

(Keywords: regression, Whiteboard: [p=1][not-part-of-initial-sprint])

Attachments

(2 files)

master 01/23 build:
Gecko-163ee61
Gaia-00d8d05

STR
Create a new message 
Add to numbers or contacts into the To field
Add an attachment
Send the message
Once sent, open it and tap on the header
Once the recipient's details view is shown, go back tapping on '<' button

EXPECTED
To go back there should be the '<' icon

ACTUAL
Instead of the back button, it is shown the close 'x' one

With today's buri v1.3 build, the back icon is shown as expected:
Gecko-6840e8c
Gaia-744fb69
Hey Steve, can you have a look ?
Flags: needinfo?(schung)
(In reply to Julien Wajsberg [:julienw] from comment #1)
> Hey Steve, can you have a look ?

Sure, but we need more info from visual because another related message report view apply 'x' for the button.
Flags: needinfo?(schung) → needinfo?(vittone)
Steve, the message report view needs "x", but the group view needs "<" :)
Yes, in this case should be an arrow, but also we should be adding a transition (like in the video) to make it more meaningful.
Flags: needinfo?(vittone)
Yeah, we were waiting for bug 881469 for the transition. (not sure it will be _really_ easier though)
comms triage: not blocking v1.4, ask for approval when ready. In case it is not part of v1.4 it should be fixed in v1.5
blocking-b2g: 1.4? → 1.5?
Steve, is it something that can be fixed along with the 1.5 visual refresh? thanks
Flags: needinfo?(schung)
Ya, we could definatly fix it in visual refresh.
Flags: needinfo?(schung)
thanks Steven, then this is part of the 1.5 visual refresh
blocking-b2g: 1.5? → ---
As per comment 5, we're blocked by 881469 on transition part.
Depends on: 881469
Assignee: nobody → schung
Target Milestone: --- → 2.0 S2 (23may)
Whiteboard: [p=1]
blocking-b2g: --- → backlog
feature-b2g: --- → 2.0
Target Milestone: 2.0 S2 (23may) → 2.0 S3 (6june)
Attached file Link to github
Hi Julien, 
this patch simply override the back button styling when in report view, but the ultimate goal should be separate report/multi-recipient view from threadui view. Do you think we could land this styling changes patch first, or we should separate views directly and put this issue to next sprint(or even next version)?
Attachment #8429984 - Flags: review?(felash)
I think we should land this because this is part of the refresh.

Bug 961572 could be what you say. And also, I think we should add a class to the page body depending on the panel (that would also replace the "layout" dataset).
Comment on attachment 8429984 [details] [review]
Link to github

Added a suggestion on github.

Please ask a review from Oleg if you want a review before the end of the week :)
Attachment #8429984 - Flags: review?(felash)
Comment on attachment 8429984 [details] [review]
Link to github

Hey Oleg, I updated the patch based on some julien's suggestion. Could you please help with the review?
Attachment #8429984 - Flags: review?(azasypkin)
Comment on attachment 8429984 [details] [review]
Link to github

(In reply to Steve Chung [:steveck] from comment #14)
> Comment on attachment 8429984 [details] [review]
> Link to github
> 
> Hey Oleg, I updated the patch based on some julien's suggestion. Could you
> please help with the review?

Sure, everything looks fine! r=me
Attachment #8429984 - Flags: review?(azasypkin) → review+
Thanks for the review and Travis is green now.
in master: af14823a08bd20efbd83157e0f952929a5ca7773
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Blocks: sms-sprint-2
Whiteboard: [p=1] → [p=1][not-part-of-initial-sprint]
Tested and working
Hamachi 
2.0
Gecko-c5087e3
Gaia-5dfe4ec
Status: RESOLVED → VERIFIED
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.