Closed Bug 96314 Opened 23 years ago Closed 23 years ago

unable to save msg unless given .html or .txt extension

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Linux
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.5

People

(Reporter: bugzilla, Assigned: sspitzer)

References

Details

(Keywords: dataloss, platform-parity, regression, Whiteboard: [PDT])

Attachments

(1 file, 1 obsolete file)

i'm unable to save a mail message unless i provide an .html or .txt extension to
the filename. found using 2001.08.21.08-comm bits on linux --however, i've seen
it on 2001.08.15.14, so not sure how long this has been around.

1. while viewing a mail message in the 3pane window, either bring up the context
menu and select Save As, or select File > Save As > File from the main menu.
2. in the resulting file picker, either keep the default name ["mail"], or
change it to something like mail-blah.eml.
3. click the Save button. [side note: if that button is greyed-out and is
labelled as Open, just click in the File Name field. that's bug 94154.]
4. check the dir in which you tried to save the file.

result: the file isn't saved.

notes:

* this seems mailnews-specific. not a problem when saving files in the browser.
* .eml appears to be the default extension for mail messages, yes? that's the
displayed type in the file picker. odd that you cannot save with that extension.
* workarounds: if i append .html or .txt to the filename, i can save the file.
or, copying the msg as a new local folder also works [kinda kludgy].
this is a regression. using 2001.08.09.10-comm bits, i'm able to save a msg
without appending .html or .txt.
Keywords: regression
Keywords: mozilla0.9.4
QA Contact: esther → sheelar
still a problem using 2001.08.31.08-comm bits on linux. unable to repro on mac
2001.08.31.10-comm.

bug 97863, involving saving as template, also seems linux-only. related? [then
again, i currently don't have access to test this on win32.]
Seth, this really sucks. Most users won't realize that they need to put an
extention on it and may save messages and delete them from mail. Can you please
look into it. I suspect that PDT will want this for emojo and I definitely want
it for 0.9.5. Thanks.
Keywords: dataloss
Blocks: 101793
0.9.4 branch radar
Keywords: nsbranch
Whiteboard: PDT
An existing message or received message can be saved on the below mentioned
platforms.
using 2001-10-01-05 commercial build on win98 and MAC OS 9.1 and X 
This is a linux only problem.  Saving a message without extension worked on
win32 and mac.   
Keywords: pp
on linux i was able to save a message if i added a .txt extention but it
did not save the entire message. a bunch of headers went missing.
minusing for the branch. 
Keywords: nsbranchnsbranch-
testing a quick fix.
Status: NEW → ASSIGNED
.html and .txt take different code paths then .eml, .foobar or no extension at all.

also, I think this is an imap vs. local issue.  (I think it should work for
local/pop, but not for imap).

testing a fix (fingers crossed), I've also got a minor change so that if you
save as "mail" (no extension), it saves it as mail.eml (since the file is really
an .eml)



punting until after 0.9.4 is done.
this will have to wait until 0.9.4 is done, but can someone investigate this?

does it fail on linux the message you are trying to save is local or news? (not 
imap).  

does this fail, when reading a message in your imap inbox, does
File | Save As | Template work if the template folder is local?  if the 
template folder is imap?

I bet more than just saving message as a file (on linux) is broken.

I bet one of those scenarios is also busted.
tested seth's scenarios above --mind you, the account i'm using is an imap account.

a. if the msg is in a *local* folder, i can save without specifying .txt or .html
b. if the msg is in a newsgroup, i can save without specifying .txt or .html
c. trying to save a message as a template --when the Templates folder is imap--
fails if it's via the thread pane or standalone. that's bug 97863.
d. trying to save a message as a template --when the Templates folder is local--
also fails --get "unable to save the message. please check your file name and
try again later".
From today's branch build: 2001-10-03-05 linux. Some more scenarios that work
and don't work if it helps. 
-If you compose a new message and save as template to your local template
folder,  you can save the message. 
-Saving as template an existing message to the template folder from an imap
account is the problem whether it is saved to imap template folder or local
template folder.

POP account-I just tried saving an existing message from 3 pane and stand alone
without extension and the message is saved.
Saving newly composed message as well as an existing message to local template
folder and pop template folder worked on linux for pop account. 

forgot to mention: the tests in my 2001-10-03 13:59 comments were done using
2001.10.03.08-trunk comm bits.
found the problem.

we are setting up the file stream and then delete the file spec.

here comes the patch.  simple patch, might be good for the branch.
this fixes the problem, but I'm noticing some line ending issues with the file 
we send.

but luckily, the .eml file we do save does get display properly when you load 
it in mozilla (even with the mixed line endings).

I'll log a seperate bug for that.
Attachment #51977 - Attachment is obsolete: true
Attachment #51975 - Flags: superreview+
I think this fix would be good for the branch, as it fixes this bug and "save 
as template" on linux.

mscott, can you re-assess?
Keywords: nsbranch-
Comment on attachment 51975 [details] [diff] [review]
patch

sr=bienvenu
r=naving
Comment on attachment 51975 [details] [diff] [review]
patch

a=asa (on behalf of drivers) for checkin to 0.9.5
Attachment #51975 - Flags: approval+
fixed on the trunk for 0.9.5
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla0.9.5
tested using 2001.10.04.08-trunk comm bits on linux. looks good!

* save as file from an imap inbox works [gave a filename w/o an extension].
* save as file from a local folder works [gave a filename w/o an extension].
* save as file from a newsgroup works [gave a filename w/o an extension].
* save as template from an imap inbox works when Templates is an imap folder.
* save as template from an imap inbox works when Templates is a local folder.
thanks for QA'ing this bug so quickly sairuh. I think I'm going to take it to
PDT today since we have a QA'ed fix in hand already. 
Blocks: 99508
Keywords: nsbranch+
This was resolved | fixed, but it has not been checked into the trunk. Reopen.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: PDT → [PDT]
pls check this into the branch - PDT+
Jaime meant to say it hasn't been checked into the 094 branch yet. It is fixed
on the trunk.
fixed on branch and trunk.
Status: REOPENED → RESOLVED
Closed: 23 years ago23 years ago
Resolution: --- → FIXED
vrfy fixed on the branch with 2001.10.05.04-0.9.4 linux bits. ran the same tests
as in my 2001-10-04 14:21 comments.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.