Closed Bug 963446 Opened 8 years ago Closed 5 years ago

Extend SyncAccountDeletedService to handle deleting client record for Firefox Accounts + Sync 1.5

Categories

(Firefox for Android Graveyard :: Android Sync, defect)

All
Android
defect
Not set
normal

Tracking

(fennec+)

RESOLVED WONTFIX
Tracking Status
fennec + ---

People

(Reporter: rnewman, Unassigned, Mentored)

References

Details

(Whiteboard: [qa+][lang=java])

No description provided.
Whiteboard: [qa?]
tracking-fennec: --- → 30+
Priority: -- → P2
Whiteboard: [qa?] → [qa?][parallel]
Blocks: 977161
Blocks: 980983
Michael, I seem to recall you working on this -- true?
Assignee: nobody → michael.l.comella
Status: NEW → ASSIGNED
Hmm, well, I copy pasta'd the code to a FxAccountDeletedService in bug 957894 - is that acceptable?
Summary: Extend SyncAccountDeletedService to handle Firefox Accounts → Extend SyncAccountDeletedService to handle deleting client record for Firefox Accounts + Sync 1.5
(In reply to Michael Comella (:mcomella) from comment #2)
> Hmm, well, I copy pasta'd the code to a FxAccountDeletedService in bug
> 957894 - is that acceptable?

We do a little more for Sync 1.1: we delete the local client record, if we can.  This is a little trickier with FxA + Sync 1.5, since it's not easy to arrange to talk to a Sync 1.5 storage endpoint (we have lots of code to make that happen smoothly).  We'd like to do similar, at least in the easy cases.
Michael, status update?
tracking-fennec: 30+ → +
(In reply to Richard Newman [:rnewman] from comment #4)
> Michael, status update?

My apologies - I lost track of this and haven't been actively working on it. I can probably start working on it before the end of the week, though feel free to snag it if it's urgent.
Spoke with nalexander on IRC and he mentioned this is an uncommon edge case for non-testers, so I'm going to put my efforts elsewhere. Here's some more useful info for completing this ticket:

<mcomella> rnewman: I was looking bug 963446, but I'm actually not sure what to do - what is the client record?
<nalexander> mcomella: the record in the clients collection.
<nalexander> mcomella: uploaded in SyncCLientsEngineStage.

Which means we're deleting the client record from the server.
Assignee: michael.l.comella → nobody
Status: ASSIGNED → NEW
Mentor: michael.l.comella
Priority: P2 → --
Whiteboard: [qa?][parallel] → [qa+][lang=java]
No longer blocks: 977161
filter on [mass-p5]
Priority: -- → P5
mcomella, did you end up getting this done in another bug?
Flags: needinfo?(michael.l.comella)
Priority: P5 → --
(In reply to Richard Newman [:rnewman] from comment #8)
> mcomella, did you end up getting this done in another bug?

No, I do not believe so.
Flags: needinfo?(michael.l.comella)
Duplicate of this bug: 932256
markh: relevant to your interests.  See also Bug 1254643.
Flags: needinfo?(markh)
(In reply to Nick Alexander :nalexander from comment #11)
> markh: relevant to your interests.  See also Bug 1254643.

Thanks Nick - we've opened bug 1264498 to filter out such devices in the meantime, and longer term we hope that the FxA device concept will help further (which is bug 1250782 and bug 1254643 which you just opened)
Flags: needinfo?(markh)
Blocks: 1319082
There's ongoing work to drive a lot of our UI which exposes the sync clients list by the more easily manageable FxA devices list; see Bug 1351104. I don't think this bug as described is worth the effort.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Product: Android Background Services → Firefox for Android
Duplicate of this bug: 1412353
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.