MLK: Memory leak of 400 bytes from 2 blocks allocated in nsNntpUrlConstructor

VERIFIED WORKSFORME

Status

MailNews Core
Networking: NNTP
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Assigned: Bienvenu)

Tracking

({mlk})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Build ID:  2001-08-21-09, Windows 2000, using Purify.

MLK: Memory leak of 400 bytes from 2 blocks allocated in nsNntpUrlConstructor
        Distribution of leaked blocks
               400 bytes from 2 blocks of 200 bytes (first block: 0x09b92ef8) 
        Allocation location
            new(UINT)+0xc        [C:\WINNT\SYSTEM32\msvcrt.DLL ip=0x580039cb]
            nsNntpUrlConstructor+0x51
[c:\moz_src\mozilla\mailnews\news\build\nsMsgNewsFactory.cpp:49 ip=0x08d213d6]
            nsComponentManager::CreateInstance(char const*,nsISupports *,nsID
const&,void * *)+0x95 [c:\moz_src\mozilla\xpcom\components\nsRepository.cpp:93
ip=0x100ba059]
            nsCreateInstanceByContractID::()(nsID const&,void * *)const+0x69
[c:\moz_src\mozilla\xpcom\components\nsComponentManager.cpp:150 ip=0x100a78e3]
            nsNntpService::NewURI(char const*,nsIURI *,nsIURI * *)+0xc1
[c:\moz_src\mozilla\mailnews\news\src\nsNntpService.cpp:1259 ip=0x08d2a31e]
            nsIOService::NewURI(char const*,nsIURI *,nsIURI * *)+0x3c8
[c:\moz_src\mozilla\netwerk\base\src\nsIOService.cpp:693 ip=0x0458d45e]
            NS_NewURI(nsIURI * *,char const*,nsIURI *,nsIIOService *)+0x126
[.\..\..\..\dist\include\nsNetUtil.h:80 ip=0x084ac3ef]
            nsImageFrame::GetRealURI(nsAString const&,nsIURI * *)+0xad
[c:\moz_src\mozilla\layout\html\base\src\nsImageFrame.cpp:1560 ip=0x0851876f]
            nsImageFrame::LoadImage(nsAString const&,nsIPresContext
*,imgIRequest * *)+0xcd
[c:\moz_src\mozilla\layout\html\base\src\nsImageFrame.cpp:1501 ip=0x08517f33]
            nsImageFrame::Init(nsIPresContext *,nsIContent *,nsIFrame
*,nsIStyleContext *,nsIFrame *)+0x3b1
[c:\moz_src\mozilla\layout\html\base\src\nsImageFrame.cpp:252 ip=0x085128f1]
Keywords: mlk

Updated

17 years ago
Blocks: 92580

Updated

16 years ago
No longer blocks: 92580
Keywords: nsbeta1
(Assignee)

Comment 1

16 years ago
OK, let me guess, you loaded a news message with an image? :-)
Assignee: sspitzer → bienvenu
Heh, yeah, sorry db.
Blocks: 110176
(Assignee)

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+

Comment 3

16 years ago
I don't see this either, clicking on multiple news messages with images. 
this and the previous one are based on leak log, but it will catch them because
the objects are refcounted.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Yeah, this worksforme too, now.  Must've pasted the wrong steps to reproduce.  
Anyways, I'll be re-Purifying news in the near future and I'll re-file clearer.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.