Closed Bug 963945 Opened 9 years ago Closed 8 years ago

In priv mode can open multiple addon tabs with shift+a

Categories

(Firefox :: Private Browsing, defect)

20 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 37
Iteration:
37.2

People

(Reporter: noitidart, Assigned: l0p3s222, Mentored)

References

Details

(Keywords: regression, Whiteboard: [lang=js][good first bug])

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

press ctrl+shift+a in private mode multiple times


Actual results:

multiple addon tabs are opened


Expected results:

only one should have opened. if there was an addon manager tab in non-priv mode it should have focused that
Blocks: 818732
Status: UNCONFIRMED → NEW
Component: Untriaged → Private Browsing
Ever confirmed: true
Keywords: regression
Version: 26 Branch → 20 Branch
Whiteboard: p=0
It's confirmed on FF29 Win 7.
Flags: firefox-backlog?
Flags: firefox-backlog? → firefox-backlog+
I believe this could be as easy as adding about:addons to the list of whitelisted urls in switchToTabHavingURI (http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#7485). If that doesn't work, we may need to investigate what's going wrong in BrowserOpenAddonsMgr (http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#6541), but it should be easy enough to reproduce this problem and test out my proposed solution.
Mentor: josh
Whiteboard: p=0 → [lang=js][good first bug] p=0
I would like to take this on. Thanks.
Assignee: nobody → l0p3s222
Attached patch First attempt at fix (obsolete) — Splinter Review
First attempt at fix
Attachment #8536969 - Flags: review?(josh)
Comment on attachment 8536969 [details] [diff] [review]
First attempt at fix

This patch is great, and it even includes a test! Thank you Michael! You can add a "r=jdm" suffix to the commit message so this is ready to merge :)
Attachment #8536969 - Flags: review?(josh) → review+
I've pushed this to our automated testing infrastructure; you should consider applying for access too: https://www.mozilla.org/hacking/committer/
Adding reviewers to message as requested.
The results from the push to try are all green, so this is ready to be checked in!
Keywords: checkin-needed
Comment on attachment 8536969 [details] [diff] [review]
First attempt at fix

For future reference, when attaching a new version it's a good practice to mark the old one as obsolete.
Attachment #8536969 - Attachment is obsolete: true
https://hg.mozilla.org/integration/fx-team/rev/7ad4cbf21299
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [lang=js][good first bug] p=0 → [lang=js][good first bug] p=0[fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/7ad4cbf21299
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [lang=js][good first bug] p=0[fixed-in-fx-team] → [lang=js][good first bug] p=0
Target Milestone: --- → Firefox 37
Iteration: --- → 37.2
Flags: qe-verify?
Whiteboard: [lang=js][good first bug] p=0 → [lang=js][good first bug]
Setting as qe-verify- since this has a test (browser/base/content/test/general/browser_bug963945.js).
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.