[curated groups] Groups that require membership requests should show a membership pending message

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mbrandt, Assigned: wbowling)

Tracking

2014-02.1

Details

(Whiteboard: [curated groups ux testing], URL)

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 8366188 [details]
qa - screenshot of feature suggestion on stage

The lack of a persistent status message for pending a curated group memberships could lead to confusion.

Steps to reproduce:
1. join a group a curated group that requires stewards approval; ex: https://mozillians.allizom.org/group/sf-monument/
2. notice the message, "Your membership request is pending approval by the group curator."
3. navigate away from the group page and then return (or simply refresh the page)

Expected:
The message persists. Optimally it would be nice if the message was in a more contextual placement, next to the join/leave group button.

Actual:
Upon refreshing the page the "Your membership request is pending approval by the group curator" message does not persist.
This is blocking launch. 

:wbowling, can you suggest a good UI pattern for this?
:dpoirier, can you take it on?
Flags: needinfo?(wbowling)
Flags: needinfo?(dpoirier)
I'll do an initial simple implementation, just displaying something simple next to the Leave Group button if the user's membership is pending, and hopefully :wbowling can design a final UI and modify from my starting point.
wbowling: initial implementation is at https://github.com/caktus/mozillians/tree/964434-membership-pending-message, let me know if you have questions, otherwise I'll leave the rest to you.
Flags: needinfo?(dpoirier)
(Assignee)

Comment 4

5 years ago
Created attachment 8367966 [details]
Screen Shot 2014-01-30 at 11.32.55 AM.png

dpoirier: Since Edit Group and Delete Group have been appearing inside the "details" box I'm inclined to move the "Leave Group" button up there too. Un-Curated groups don't have that little box though, right?

here's a mocked up 'status bar'. there might already be a standard one of these though.

Style notes to self:
element.style {
background-color: #F5F5DC;
color: #FF8F00;
display: block;
text-align: center;
margin: 20px 0;
border-radius: 3px;
padding: 4px;
}
Flags: needinfo?(wbowling)
Assignee: nobody → wbowling
Status: NEW → ASSIGNED
If someone's membership request is pending, should we change the text on the "Leave Group" button? To something like "Cancel membership request", though that seems too long to put on a button?

Also, I think it makes more sense for the Join and Leave buttons to stay down by the membership list, rather than up in the group details. Right now, only the curator ever sees buttons in the group details, and that makes sense to me. The buttons there are for changing the group details, while the Join or Leave button has to do with my membership status.

Comment 7

5 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/ebf999d3d4c0f8bd70dcb438ec2035c936f49b0e
[Fix bug 964434] show a membership pending message

Squashed commits:
- cleaned up whitespace
- restored placement of join.leave buttons
- Styled pending status bar just above list of members. Moved “Leave Group” button into the info - box where other buttons appear.

https://github.com/mozilla/mozillians/commit/0bd129070abb4f2b89d5a00cfe6c460b349a2e13
Merge pull request #792 from caktus/964434-membership-pending-message

[Fix Bug 964434] membership pending message

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Version: other → next
(Reporter)

Comment 8

5 years ago
Created attachment 8371549 [details]
qa - reopened

Reopening:

It doesn't appear the 'membership pending' message persists.

steps to reproduce:
1. join a group that requires a curator to allow joining (https://mozillians.allizom.org/en-US/group/sf-monument/)
2. browse away from that group
3. return to that groups page

Expected:
A message should persist stating that membership is still pending.
(Reporter)

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 9

5 years ago
Bumping back to fixed - stage has been updated with latest head.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

5 years ago
Created attachment 8371674 [details]
qa - verified on stage

QA verified on stage. Looks fantastic .. thank you for slipping this into the release.

Membership pending message now persists.
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
Version: next → 2014-02.1
You need to log in before you can comment on or make changes to this bug.