[Sora][music player]the playing song would not stop instantly when coming one call

RESOLVED DUPLICATE of bug 1003025

Status

Firefox OS
Gaia::System::Window Mgmt
P1
normal
RESOLVED DUPLICATE of bug 1003025
4 years ago
4 years ago

People

(Reporter: sync-1, Assigned: alive)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Reporter)

Description

4 years ago
Mozilla build ID: 20140118004001
 
 DEFECT DESCRIPTION:
 The playing song would not stop instantly and it will play both song and ringtone for a short while
 
  REPRODUCING PROCEDURES:
 1.Launch music player;
 2.Select one song to play;
 3.During playing,incoming one call.
 
  EXPECTED BEHAVIOUR:
 The playing song should stop instantly when coming one call.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:5/5
I think this was intentional change in 1.2.

Marco - Can you confirm?
Flags: needinfo?(mchen)

Comment 2

4 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=908525#c51

Please refer to the comment above.
It is caused by 3 seconds delay of setting visibility change into background app when attention screen shown.
And that bug indicated this would be improved on v1.5. 

Hi Alive,

Just NI you for adding this bug into your radar. Thanks.
Component: Gaia::Music → Gaia::System::Window Mgmt
Flags: needinfo?(mchen) → needinfo?(alive)
Assignee: nobody → alive
Depends on: 927862
Flags: needinfo?(alive)

Comment 3

4 years ago
Nominated as 1.3? for it's regession issue.
blocking-b2g: --- → 1.3?

Updated

4 years ago
Keywords: regression, regressionwindow-wanted
This is definitely not a regression bug a old-old-old issue.
http://bugzil.la/attention-window would fix this and http://bugzil.la/(app-audio-channel is the long term solution.
http://bugzil.la/app-audio-channel I mean.

(In reply to Alive Kuo [:alive][NEEDINFO!][:艾莉芙][Paris 2/3-2/7] from comment #4)
> This is definitely not a regression bug a old-old-old issue.
> http://bugzil.la/attention-window would fix this and
> http://bugzil.la/(app-audio-channel is the long term solution.
Clear v1.3? and regression. Renom if disagree.
blocking-b2g: 1.3? → ---
Keywords: regression, regressionwindow-wanted

Comment 7

4 years ago
Please land patch to 1.3 if you already got a solution, thanks.
blocking-b2g: --- → 1.3?
This is feature work and would like Alive to take some time to test and fix the issue.
blocking-b2g: 1.3? → 1.4?
Triage: This will be covered by non-trivial feature works mentioned in comment 4 in future release.

Marking WONTFIX for v1.3/1.4.
Status: NEW → RESOLVED
blocking-b2g: 1.4? → ---
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
Duplicate of this bug: 973160

Comment 11

4 years ago
[Blocking Requested - why for this release]:
This Bug is postponed for v1.3/1.4
But it's still happening in v2.0
Status: RESOLVED → REOPENED
blocking-b2g: --- → 2.0?
Flags: needinfo?(wehuang)
Resolution: WONTFIX → ---

Comment 12

4 years ago
[Triage] de-tag and dup to bug 1003025.

Hi hanp: pls try the patch we are going to put in 1003025
Status: REOPENED → RESOLVED
blocking-b2g: 2.0? → -
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(wehuang)
Resolution: --- → DUPLICATE
Duplicate of bug: 1003025

Comment 13

4 years ago
(In reply to Wesly Huang from comment #12)
> [Triage] de-tag and dup to bug 1003025.
> 
> Hi hanp: pls try the patch we are going to put in 1003025
> 
> *** This bug has been marked as a duplicate of bug 1003025 ***

Hi, Wesly, I've seen the page in bug 1003025 and found no patch there.
Do you mean the mentioned patch for bug 927862 ?
Seems that is a huge patch, like rachelle yang said, too risky.
I don't think we can merge it easily in our branch.

Updated

4 years ago
Flags: needinfo?(wehuang)

Comment 14

4 years ago
Hi Hanp:

I mean use to patch mentioned in comment#30 or comment#32 of 1003025. Not the one in bug 927862 since it's indeed big and risky one as Rachelle said.
Flags: needinfo?(wehuang) → needinfo?(hanp)

Comment 15

4 years ago
Hi Wesly, this patch works, thank you.
Flags: needinfo?(hanp)

Comment 16

4 years ago
Thanks Hanp, it's good to know!
You need to log in before you can comment on or make changes to this bug.