Unable to get MAC address from Tarako device

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: davehunt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
It appears we're unable to get the MAC address from a Tarako device. This is obtained and submitted alongside the performance results to DataZilla, and without it we may not be able to display results.

To replicate:
1. pip install marionette-client
2. Enter the following in a Python interactive shell:

> from marionette import Marionette
> m = Marionette()
> m.start_session()
> print m.execute_script('return navigator.mozWifiManager;')

Expected:
A dict should be printed containing a valid value for the macAddress key.

Actual:
macAddress value is None

{u'macAddress': None, u'connectionInfoUpdate': None, u'ondisabled': None, u'onstatuschange': None, u'enabled': False, u'onenabled': None, u'connection': {u'status': u'disconnected', u'__exposedProps__': {u'status': u'r', u'network': u'r'}, u'network': None}, u'connectionInformation': None}
The root cause is that wifi is not working at all for now on these devices. If you can workaround while this is fixed...
(Reporter)

Comment 2

5 years ago
(In reply to Fabrice Desré [:fabrice] from comment #1)
> The root cause is that wifi is not working at all for now on these devices.
> If you can workaround while this is fixed...

I've raised bug 964835 so we can provide an override on the command line. Is there any other alternate device identifier we could use?
Flags: needinfo?(fabrice)
(In reply to Dave Hunt (:davehunt) from comment #2)
> 
> I've raised bug 964835 so we can provide an override on the command line. Is
> there any other alternate device identifier we could use?

Not that I know when you have no wifi and no sim card :(
Flags: needinfo?(fabrice)
(In reply to Fabrice Desré [:fabrice] from comment #3)
> (In reply to Dave Hunt (:davehunt) from comment #2)
> > 
> > I've raised bug 964835 so we can provide an override on the command line. Is
> > there any other alternate device identifier we could use?
> 
> Not that I know when you have no wifi and no sim card :(

I've got one working AT&T SIM card in there, now -- with both data and voice.  But as this is a DSDS device, do we need two?
Check in the settings app in Device info > More info is you can get the IMEI
(Reporter)

Comment 6

5 years ago
We'd need an identifier for the device rather than the SIM, as that can/will travel between devices. In bug 964835 I allow a machine name to be set on the command line. If there's no other unique identifier for the device, we can just pick an arbitrary name such as tarako-1.

Comment 7

5 years ago
Brian, could you confirm if this is still valid?
Flags: needinfo?(bhuang)
Flags: needinfo?(bhuang) → needinfo?(brhuang)
Askeing, could you help to check if current Tarako build can provide the information? thanks
Flags: needinfo?(brhuang) → needinfo?(fyen)
>>> return navigator.mozWifiManager;
{u'macAddress': u'00:63:eb:xx:xx:xx', u'connectionInfoUpdate': None, u'ondisabled': None, u'onstatuschange': None, u'enabled': True, u'onenabled': None, u'connection': {u'status': u'disconnected', u'__exposedProps__': {u'status': u'r', u'network': u'r'}, u'network': None}, u'connectionInformation': None}

WFM now.

BuildID   20140312075534
gaia=4179695b gecko=4571a19c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(fyen)
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

5 years ago
I've just checked this too and can also confirm that it's fixed.
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.