Closed Bug 965116 Opened 6 years ago Closed 6 years ago

figure out when to trigger the "must sign in again" UI

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: Gavin, Assigned: ckarlof)

References

Details

(Whiteboard: [qa?])

Attachments

(1 file, 1 obsolete file)

The UI in bug 964929 is currently never triggered. We need to show it when auth failures occur that can be resolved by signing in again.
Whiteboard: [qa?]
Summary: figure out when to trigger the "must sign in again" UI → figure out when to trigger, and trigger, the "must sign in again" UI
Summary: figure out when to trigger, and trigger, the "must sign in again" UI → figure out when to trigger the "must sign in again" UI
Assignee: nobody → ckarlof
Comment on attachment 8368933 [details] [diff] [review]
0001-Add-basic-error-handling-to-browserid_identity-to-re.patch

Review of attachment 8368933 [details] [diff] [review]:
-----------------------------------------------------------------

::: services/sync/modules/browserid_identity.js
@@ +403,4 @@
>      let tokenServerURI = Svc.Prefs.get("tokenServerURI");
>      let log = this._log;
>      let client = this._tokenServerClient;
> +    let fxaService = this._fxaService;

this was a bit of a mess before, but there is already a module global "fxAccounts" which can be used whereever this._fxaService is used - so I think we should clean this up now in this block.

@@ +426,5 @@
>      }
>  
> +    function getAssertion() {
> +      let audience = Services.io.newURI(tokenServerURI, null, null).prePath;
> +      return fxaService.getAssertion(audience)

please reindent this block

@@ +445,3 @@
>        .then(assertion => getToken(tokenServerURI, assertion))
>        .then(token => {
> +        // TODO: have it be only 80% of the duration, to avoid sync storage errors

this sounds serious enough to get a bug on file and referenced here, plus expand on the comment

@@ +453,5 @@
> +        // TODO: write tests to make sure that different auth error cases are handled here
> +        // properly: auth error getting assertion, auth error getting token (invalid generation
> +        // and client-state error)
> +        if (err instanceof AuthenticationError) {
> +          this._log.error("Authentication error in _fetchTokenForUser " + err.message);

add a ':' to the end of the literal
Attachment #8368933 - Flags: review?(mhammond) → review+
Attachment #8368933 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/0646c8305465
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 966160
You need to log in before you can comment on or make changes to this bug.