Closed Bug 965778 Opened 10 years ago Closed 10 years ago

[Messages] Display contact photo in each message shown in a conversation view

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 963017

People

(Reporter: vittone, Unassigned)

Details

Attachments

(1 file)

Attached image sender-picture.png
In the message thread, after the visual refresh, the sender has a picture. 

As Ayman commented: "We do not have the facility on the phone at the moment for users to add an image of themselves"

In order to implement the design proposal as is, we need to develop a feature related to this.
blocking-b2g: --- → 1.4?
Blocks: 951672
Flags: needinfo?(wmathanaraj)
I'm not really sure this should be in the SMS app. I think it should be in the Settings app, and asked already during FTU. The image would then be either stored in Settings or DeviceStorage and the SMS app or other apps could retrieve it.

So there are more UX implication (hence needinfo the broader UX team) and technical implications (hence needinfo Vivien).
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(21)
Summary: [SMS] Ability to add sender's picture to show in the Messages App → [Messages] Display contact photo in each message shown in a conversation view
Flagging Jacqueline on FTU and Neo on Settings, though please note that it is Chinese New Year and so Taipei UX will likely not respond until post holiday.
Flags: needinfo?(nhsieh)
Flags: needinfo?(jsavory)
Flags: needinfo?(firefoxos-ux-bugzilla)
Please assign to another UX designer. Thanks
Flags: needinfo?(nhsieh) → needinfo?(swilkes)
Flagging Omega to comment on whether or not this is appropriate for Settings. Jacqueline can still cover the FTU comment but we've just wrapped up a work week so responses are a bit behind here.
Flags: needinfo?(swilkes) → needinfo?(ofeng)
ni? Victoria, is the sender's picture necessary? I mean, is this defined in the Messages UX spec, or coming from visual refresh?
Currently we don't have a section for personal information in Settings. If the sender's picture is necessary, we can add an section for it. Or the better idea I think is adding a contact "Me" in Contacts app.
Flags: needinfo?(ofeng) → needinfo?(vpg)
(In reply to Julien Wajsberg [:julienw] from comment #1)
> I'm not really sure this should be in the SMS app. I think it should be in
> the Settings app, and asked already during FTU. The image would then be
> either stored in Settings or DeviceStorage and the SMS app or other apps
> could retrieve it.
> 
> So there are more UX implication (hence needinfo the broader UX team) and
> technical implications (hence needinfo Vivien).

Well, can't we simply let the user create his own contact ? Then he can assign any picture he want.
Flags: needinfo?(21)
Yep I didn't think of it, this looks fine.

But then we need a way to say "get my own contact card" from an activity or mozContact.
(In reply to Omega Feng [:Omega] from comment #5)
> ni? Victoria, is the sender's picture necessary? I mean, is this defined in
> the Messages UX spec, or coming from visual refresh?
> Currently we don't have a section for personal information in Settings. If
> the sender's picture is necessary, we can add an section for it. Or the
> better idea I think is adding a contact "Me" in Contacts app.

This comes from a proposal made for the Visual Refresh. It's not a feature of SMS but yes a need derivated from that proposal.
Thanks.
Flags: needinfo?(vpg)
Flags: needinfo?(wmathanaraj)
Visual refresh is due for 1.5.
blocking-b2g: 1.4? → 1.5?
this is part of the visual refresh for 1.5
blocking-b2g: 1.5? → ---
In the lastest spec attachment 8394791 [details], there is no need to show contact photo in the conversation view. I'll close it as invalid first. Please reopen it if spec changes and it becomes necessary for conversation view.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
Hi,

Not needed for 2.0 but something to be consider for future releases, please see https://bugzilla.mozilla.org/show_bug.cgi?id=963017#c3 comment from visual design team. Bug 963017 was added to backlog so marking this bug as duplicate of that.
Resolution: INVALID → DUPLICATE
No longer blocks: 951672
Blocks: 951672
No longer blocks: 951672
As this won't be included in FTU, but instead contacts or settings, I'm removing the flag.
Flags: needinfo?(jsavory)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: