Intermittent TEST-UNEXPECTED-FAIL | test_conference.js | got connected, expected held | conference.state - got connected, expected held

RESOLVED DUPLICATE of bug 943275

Status

RESOLVED DUPLICATE of bug 943275
5 years ago
16 days ago

People

(Reporter: KWierso, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/d2c4e022d5ac
slave: tst-linux64-ec2-135



12:27:41     INFO -  INFO Received 'callschanged' event for the conference Thu Jan 30 2014 15:27:40 GMT-0500 (EST)
12:27:41     INFO -  INFO Received 'callschanged' event for the telephony Thu Jan 30 2014 15:27:40 GMT-0500 (EST)
12:27:41     INFO -  INFO Received 'statechange' event for the conference Thu Jan 30 2014 15:27:40 GMT-0500 (EST)
12:27:41     INFO -  INFO Call list is now: inbound from 5555550201 : active,OK Thu Jan 30 2014 15:27:40 GMT-0500 (EST)
12:27:41     INFO -  INFO Remote hanging up the call. Thu Jan 30 2014 15:27:40 GMT-0500 (EST)
12:27:41     INFO -  INFO Received 'disconnected' call event. Thu Jan 30 2014 15:27:40 GMT-0500 (EST)
12:27:41     INFO -  INFO == Test TearDown == Thu Jan 30 2014 15:27:40 GMT-0500 (EST)
12:27:41     INFO -  END LOG:
12:27:41     INFO -  ======================================================================
12:27:41     INFO -  FAIL: None
12:27:41     INFO -  ----------------------------------------------------------------------
12:27:41     INFO -  Traceback (most recent call last):
12:27:41     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 143, in run
12:27:41     INFO -      testMethod()
12:27:41     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 478, in runTest
12:27:41     INFO -      '%d tests failed:\n%s' % (results['failed'], '\n'.join(fails)))
12:27:41     INFO -  AssertionError: 1 tests failed:
12:27:41     INFO -  TEST-UNEXPECTED-FAIL | test_conference.js | got connected, expected held | conference.state
12:27:41     INFO -  ----------------------------------------------------------------------
12:27:41     INFO -  Ran 1 test in 25.116s
12:27:41     INFO -  FAILED (failures=1)



12:41:44     INFO -  01-30 15:27:32.805    45    45 I Gecko   : MARIONETTE LOG: INFO: Answering the incoming call.
12:41:44     INFO -  01-30 15:27:32.823    45    45 I Gecko   : MARIONETTE LOG: INFO: Received 'connecting' call event for incoming call.
12:41:44     INFO -  01-30 15:27:32.837    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | event.call - [object XrayWrapper [object TelephonyCall]] should equal [object XrayWrapper [object TelephonyCall]]
12:41:44     INFO -  01-30 15:27:32.837    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | call state - connecting should equal connecting
12:41:44     INFO -  01-30 15:27:33.182    45    45 I Gecko   : MARIONETTE LOG: INFO: Received 'connected' call event for incoming call.
12:41:44     INFO -  01-30 15:27:33.192    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | event.call - [object XrayWrapper [object TelephonyCall]] should equal [object XrayWrapper [object TelephonyCall]]
12:41:44     INFO -  01-30 15:27:33.206    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | call state - connected should equal connected
12:41:44     INFO -  01-30 15:27:33.206    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | undefined - true was true, expected true
12:41:44     INFO -  01-30 15:27:33.223    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | telephony.active - [object XrayWrapper [object TelephonyCall]] should equal [object XrayWrapper [object TelephonyCall]]
12:41:44     INFO -  01-30 15:27:33.223    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | telephony.calls - 1 should equal 1
12:41:44     INFO -  01-30 15:27:33.223    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | undefined - [object XrayWrapper [object TelephonyCall]] should equal [object XrayWrapper [object TelephonyCall]]
12:41:44     INFO -  01-30 15:27:33.223    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-UNEXPECTED-FAIL | test_conference.js | conference.state - got connected, expected held
12:41:44     INFO -  01-30 15:27:33.223    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | conference.calls - 2 should equal 2
12:41:44     INFO -  01-30 15:27:33.238    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | undefined - [object XrayWrapper [object TelephonyCall]] should equal [object XrayWrapper [object TelephonyCall]]
12:41:44     INFO -  01-30 15:27:33.238    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | undefined - [object XrayWrapper [object TelephonyCall]] should equal [object XrayWrapper [object TelephonyCall]]
12:41:44     INFO -  01-30 15:27:33.263    45    45 I Gecko   : 1391113653269	Marionette	INFO	sendToClient: {"emulator_cmd":"gsm list","id":193}, -1, {d0e9d178-d9e3-4c0a-9bd6-30996fcee645}
12:41:44     INFO -  01-30 15:27:33.295    45    45 I Gecko   : MARIONETTE LOG: INFO: Call list is now: outbound to  5555550101 : held,inbound from 5555550201 : held,inbound from 5555550202 : active,OK
12:41:44     INFO -  01-30 15:27:33.295    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | emulator calllist - outbound to  5555550101 : held should equal outbound to  5555550101 : held
12:41:44     INFO -  01-30 15:27:33.295    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | emulator calllist - inbound from 5555550201 : held should equal inbound from 5555550201 : held
12:41:44     INFO -  01-30 15:27:33.295    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | emulator calllist - inbound from 5555550202 : active should equal inbound from 5555550202 : active
12:41:44     INFO -  01-30 15:27:33.295    45    45 I Gecko   : MARIONETTE TEST RESULT:TEST-PASS | test_conference.js | emulator calllist - OK should equal OK
12:41:44     INFO -  01-30 15:27:33.313    45    45 I Gecko   : MARIONETTE LOG: INFO: Add 1 calls into conference.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Andrew, can you please help find an owner for this frequent Mnw orange?
Flags: needinfo?(overholt)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Ken, can someone on your team investigate the failures here?
Flags: needinfo?(overholt) → needinfo?(kchang)
Comment hidden (Treeherder Robot)

Comment 33

5 years ago
Hsinyi, can you please help this bug?
Flags: needinfo?(kchang) → needinfo?(htsai)
I already have the patch (and has been pushed) on bug 943275. Though the failure messages are sometimes displaying |Intermittent TEST-UNEXPECTED-FAIL | test_conference.js | ScriptTimeoutException: timed out| as bug 943275, the log shows these two bugs share the same root cause. 

Mark this as duplicate.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(htsai)
Resolution: --- → DUPLICATE
Duplicate of bug: 943275
You need to log in before you can comment on or make changes to this bug.